TechSpot

USB problem

By Xythoces
Aug 8, 2006
Topic Status:
Not open for further replies.
  1. I have an external WIFI antenna for my laptop which I connect via a USB cable.

    My problem is that the Antenna is "Hi-speed" enabled, and I have no Hi-speed USB ports on my laptop, that I know of. Every time I plug it in, after a few minutes, I get kicked off by a message that tells me to plug it into a Hi-speed USB port.

    Normally, I wouldn't have a problem, except that it interrupts my connection, and it takes a few minutes for it to re-connect again.

    Is there any way that I could get rid of that annoying pop-up?
  2. Vigilante

    Vigilante TechSpot Paladin Posts: 2,120

    First you might want to post the exact error message, to aid in searching for fixes.

    But one thing I found, you might try, is to go in Device Manager and disable error checking for USB.
    Right-Click My Computer -> Properties -> Hardware -> Device Manager.

    Down at the bottom is the USB section. Expand that and then, on any "controller", right-click it and choose Properties. Then on the Advanced tab, you can check the box to disable error checking.

    Maybe that will do it, maybe not, but it's a start.

    Good luck!
  3. Xythoces

    Xythoces TS Member Topic Starter Posts: 29

    I think that fixed it.

    It was more like an annoying suggestion than an error, but I think that fixed it; it hasn't happened again. If it does I'll post again. Thank you.
  4. Vigilante

    Vigilante TechSpot Paladin Posts: 2,120

    Ok cool, I'll remember that.
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.