TechSpot

USB Wi-Fi dongle

By Ryan Townsend
Mar 19, 2013
Post New Reply
  1. I have a USB Wi-fi dongle.

    Every-time I plug it in, It doesn't get picked up by my computer?

    When I go into device manager, It says it's plugged in and working but Windows still refuses to use it to connect to the internet.

    I'm at a loss.
     
  2. B00kWyrm

    B00kWyrm TechSpot Paladin Posts: 1,556   +18

    Have you done this?
    1. Network & Sharing Center -> Change Adapter Settings -> Enable
    2. Network & Sharing Center -> Manage Wireless Networks -> Choose your network,
    and enter the needed log-on information.
     
  3. Ryan Townsend

    Ryan Townsend TS Rookie Topic Starter Posts: 39

    It shows up; black and white and when I click enable it loads then just stays black and white and still does not show up.
     
  4. B00kWyrm

    B00kWyrm TechSpot Paladin Posts: 1,556   +18

    Erm... I am not following you.
    Could you try again.
     
  5. Ryan Townsend

    Ryan Townsend TS Rookie Topic Starter Posts: 39

    Sorry I'm rushing! Just really annoyed with this problem!

    After I click change adapter settings, and click enable on the Dongle, it stays black and white (showing that it is disabled)
     
  6. compfixing

    compfixing TS Rookie Posts: 43

    Disable it in Device Manger and Unable it again.
     
  7. B00kWyrm

    B00kWyrm TechSpot Paladin Posts: 1,556   +18

    Okay... :confused:
    Which OS (and sp if appliable) are you using? (Win7? Vista? XP? other?)
    And who made the usb dongle? Is there a model number?

    For me (Win7 - Home - 64 bit - SP1)
    Disabled is more grey than black and white...
    and there are some color components when enabled.

    Do you have administrator privileges?

    And when you "right click" on the dongle after trying to enable it...
    does it offer the option still to "enable" or does the option now say "disable"?

    After enabling... you might try rebooting,
    though I would think that should not usually be needed. :confused:

    If all else fails...
    make sure you have the CORRECT drivers on a drive / thumb or cd,
    then go to hardware manager
    and try updating the drivers by pointing to the source you want to use.

    Finally, if still no joy, you might go to device manager
    and get "harware ids" and "compatible ids", (for YOUR device, obviously).
    This will be under (right click) properties -> (tab) details,
    the second and third menu items (if your OS is the same as mine.)
    And we can work to make sure you do have the right drivers.
    This SHOULD not be this difficult! If I can't get you there, I know a couple of guys to ask though. :)
     
  8. Ryan Townsend

    Ryan Townsend TS Rookie Topic Starter Posts: 39

    My device manager stops responding, need to un plug the Dongle to make it responsive again...
     
  9. B00kWyrm

    B00kWyrm TechSpot Paladin Posts: 1,556   +18

    Something else to try is using a different USB port.

    Edit/Add -
    Also have seen situations where AV/Firewall software prevented the proper installation of drivers. You may need to temporarily disable or even uninstall your AV/Firewall, in order to get installed, then reinstall again. If they are paid products, before uninstalling, make sure you have the necessary keys to reinstall.
     
    LookinAround likes this.
  10. Ryan Townsend

    Ryan Townsend TS Rookie Topic Starter Posts: 39


    I have; Windows 7 64 bit, Service pack 1.
    and yes it was grayed out not black and white, excuse me.

    I do have Admin privilidges.
    It says I can enable it, when I click enable it stays disabled or crashes explorer.exe and I have to unplug the dongle to make explorer.exe respond again.

    I've tried enabling and rebooting tones of times.

    All drivers seem to be fine, I use the ones with the provided disc or I let windows find the correct drivers (I have tried both)

    I will try the Device Manager thing now.

    I have tried disabling the Anti-Virus but not uninstalling, I will try shortly
     
  11. B00kWyrm

    B00kWyrm TechSpot Paladin Posts: 1,556   +18

    We may get more information by examining "events",
    but right now I am suspecting a bad usb port OR a bad dongle.
    If your dongle were not hanging your system, I would have different suspicions.
    But not being able to enable and having it hang the system...

    If it fails in all ports, then I would suspect the dongle.
    The one thing to try before giving up on that angle tho' is as suggested above...
    Uninstall the drivers and hardware from device manager and start over.

    Also... something I have noticed is that sometimes devices made for USB2 (or even USB1)
    act flakey in a SuperSpeed USB port.
    I have a logitech wireless keyboard and mouse combo,
    and for best results I keep that wifi dongle in my usb2 ports.
     
     
  12. Ryan Townsend

    Ryan Townsend TS Rookie Topic Starter Posts: 39

    I see the Compat Id's and the Hardware Id's what now?

    I will try more USB ports, this can't be the dongle as I have tried 2 more dongles which I have in my hous and all have the same results... I will try with different USB ports and get back to you.
     
  13. B00kWyrm

    B00kWyrm TechSpot Paladin Posts: 1,556   +18

    Those ids can be used to make sure you get the right drivers.
    But, if you have the cd, that is the place to start, we may not need them.

    We need to get your system to recognize properly the presence of the dongle.
    I am going to ask a couple of others to look in here.
    One is the "go to" guy for networking issues, and the other a device driver guru.
     
  14. Ryan Townsend

    Ryan Townsend TS Rookie Topic Starter Posts: 39

    Ok

    Ok thanks!
     
  15. jobeard

    jobeard TS Ambassador Posts: 13,522   +336

    hmm; These two statements are inconsistent and at least confuse me and I am afraid that someone else might be too.

    Let's get the device/model of the USB WiFi Dongle for a start so we're all on the same page.

    Secondly, WiFi Dongles I have seen add a WiFi device to a system which did not previously have WiFi and the intent is to access (connect to) an existing WiFi Router - - NOT another computer.

    So, what router do you have, does your system also have a Wifi adapter (I would guess not) and
    do you know the SSID and PassPhrase for that router?
     
  16. Ryan Townsend

    Ryan Townsend TS Rookie Topic Starter Posts: 39

    The Model/Device is one of the following;

    Wireless USB Adapter(RT2070,RT3070,RT2770,RT3072,RT3572,RT3370)
    Im sure it does not matter what one it is exactly, as they all have one particular driver, which is on the disc.

    Oh Yes I do want to connect to my router not my computer, when I said my computer wasn't picking it up, I ment my computer wasn't showing anything plugged in, in the network and sharing center, along with the internet status Icon in the taskbar.

    My computer does not have a Wi-fi adapter hence why I have a dongle as you stated. I do know the SSID and PassPhrase for my router.
     
  17. Ryan Townsend

    Ryan Townsend TS Rookie Topic Starter Posts: 39

    HOLD UP!

    My I have a driver problem that might be related, it's an Ethernet Controller, there's a yellow triangle with an exclamation mark in it, its also listed on the other devices tab on the Device Manager?! Could this be the root of all this evil?!
     
  18. LookinAround

    LookinAround TechSpot Chancellor Posts: 8,398   +169

    I don't think that would be the "root of all evil". That said, may be good to step back and first check on your network adapters, their drivers and status. If that much looks good, I'm sure jobeard can help you get them "networked"

    Your statements beg the question: If your ethernet controller has a problem and your wireless adapter isn't working either, is that machine connected to the internet at all??? If so, how?

    That said, please provide the following info
    1) Sorry if I missed it earlier but what's the make/model of your computer? I saw you said you're running Win 7 64-bit.
    2) List any Problem devices
    • Make sure devices are connected and powered on
    • Click Start->Run, enter: msinfo32. Click the + sign next to Components to expand it
    • Click Problem Devices. Anything appear?
    • If yes, click on it, Ctrl-A to select all, Ctrl-C to copy it, Ctrl-V to paste into next post
    • On the other hand, if no devices are listed, tell me so

    3) See How To Report Your Computer's Device Manager Data. Upload the info to next post
     
  19. Ryan Townsend

    Ryan Townsend TS Rookie Topic Starter Posts: 39


    No my machine is not connected to the internet in any way, It has been before done so before to try out windows update to see if it can install the correct drivers.

    My computer is an; Advent Firefly FP3104, and yes I'am running Windows 7 64bit. (along with service pack 1).

    msinfo32; only lists the Ethernet Controller which then says 'the drivers for this device are not installed'.

    Ethernet ControllerPCI\VEN_8086&DEV_10EF&SUBSYS_A13019DA&REV_06\3&11583659&0&C8The drivers for this device are not installed.
     
  20. jobeard

    jobeard TS Ambassador Posts: 13,522   +336

    Google for the support page for "Advent Firefly FP3104"

    the proper drivers for all controllers on the motherboard will be there - -
    download them to a USB thumbdrive which you can then move to your system for install.

    btw: it's a major issue to have !YELLOW! or !RED! flags on devices shown by the Device Mgr,
    in particular those with which you are having problems.
     
  21. Ryan Townsend

    Ryan Townsend TS Rookie Topic Starter Posts: 39

    Ok Installed the correct Ethernet driver.

    No change. Any other suggestions?
     
  22. jobeard

    jobeard TS Ambassador Posts: 13,522   +336

    Ok, super - - did you attempt to connect your router to the PC using an ethernet cable?
    This should be your first effort to get the configuration correct.

    Once connected, get a command prompt (start->run and enter CMD) and in the command window
    enter IPCONFIG /ALL >myTCP.txt

    Attach the myTCP.txt to your follow-up or copy the content and past it as your reply.
     
  23. LookinAround

    LookinAround TechSpot Chancellor Posts: 8,398   +169

    Ryan Townsend

    Work with jobeard and get your wired Ethernet connection working first. (can make your future troubleshooting life much easier! :) )

    B00kWyrm

    Good point!

    Before reading your post the other day, I hadn't heard of AV intefering with USB wireless but just now came across this: I can’t enable my USB wireless adapter on Windows 7 (Solution) as case in point

     
  24. SBHack

    SBHack TS Rookie Posts: 32

    Sideline question: has the dongle been tested on another system to verify it is functional?

    Also after updating drivers did you power cycle the system. (It shouldn't be needed but you know how picky computers can be.)
     
  25. Ryan Townsend

    Ryan Townsend TS Rookie Topic Starter Posts: 39

    I have tried the Dongle on 2 Laptops and 1 Desktop and it works perfect, so it's deffo not the Dongle itself.
     


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.