TechSpot

Very slow web page loading (or non-existent)

By scooter125
Jul 29, 2009
  1. I have two PCs exhibiting the same problem. Extremely slow web page loading; sometimes it works ok, most often it hangs up. Seems not to be the router; download speeds are fine, I've cycled it on/off several times.

    Another odd thing I noticed: when I try to double click on a icon on my desktop, it won't work. It acts like there's not an icon there. I need to go into explorer to find the desktop folder and open from there.

    Thanks very much for any advice!
     
  2. Tmagic650

    Tmagic650 TS Ambassador Posts: 20,934   +167

    Is this slow webpage loading in both IE8 and Firefox? Your antivirus (Antivir) doesn't detect anything?
     
  3. sobhi66

    sobhi66 TS Rookie

    ok im writing this so i can post a thread and i think your problem is easy
     
  4. scooter125

    scooter125 TS Rookie Topic Starter

    IE and Firefox act the same. Avira did find something just today call the TR/Trash.Gen trojan, so that is in quarantine.
     
  5. Bobbye

    Bobbye Helper on the Fringe Posts: 16,392   +36

    No problem: Right click on Start> Explore.

    Another place for the Desktop: Control Panel> Display> Desktop tab.
     
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.