TechSpot

Video Card Installation problems

By IrishFairy
Oct 16, 2009
Topic Status:
Not open for further replies.
  1. Hi, Im a first time poster here, having some graphic card problems..

    My specs..
    AMD Athlon 64 3000+ @ 2000 MHz
    2048 MB (2 x 1024 DDR-SDRAM )
    NVIDIA GeForce FX 5200
    MSI K8T Neo-V (MS-7032)
    PCI and AGP bus

    Please dont laugh..lol..anyway..as you can see I have a crappy video card..so I just purchased an EVGA NVIDIA 8400 GS..AND a new psu, 550 watt, should be plenty to run the card.

    So..I uninstall the old drivers..even use Driver Sweeper to make sure..install the new card..and drivers..everything is fine until reboot..then I get a totally pixelated screen. Its neon colors and cant read anything on it..btw.its a PCI card..so it says..and I have both PCI and AGP bus slots, and bios is set to both.

    I also installed this 5200 just a week ago from a previous 5200 that went out. So the installation went fine with this one.

    Im not able to post a screenshot because it's my first post, but I do have one on photobucket.

    Strange thing is..I go into PC Wizard to see..or BARELY see..what its saying about the card..it is saying its PCI E..at least I THINK it says that..
    I tried getting into my bios..and no luck..I have a razor keyboard and no matter what key I hit..I cant access bios..

    What do you think is wrong..is it the graphics card itself? Just got it from Tiger Direct..hmmm
    I really cant afford to spend any more money! Im a single mom and it was bad enough buying a psu and card. HELP! :)
  2. Ritwik7

    Ritwik7 TechSpot Chancellor Posts: 2,288   +7

    If it's a PCI card just set your primary video adapter to PCI in the BIOS. Any idea what the temperatures are like?
  3. IrishFairy

    IrishFairy TS Rookie Topic Starter

    Yes, I cant get into my bios! No matter what key I press on startup, F1,F11 , delete, etc..( on the startup screen it says F11 or delete ) it just continues into Windows..I have a razor gaming keyboard and it doesnt light up until Windows loads, I dont know if that has anything to do with it.

    I did install this 5200 recently, had an older 5200 card that went out..and it was AGP, this one is PCI, so it seems to read the PCI slot fine.

    Temps according to PC Wizard:
    Processor Temperature : 27.5 °C
    Mainboard Temperature : 41 °C
    AMD Athlon 64 (Diode) : 26 °C
    Hard Disk HDS728080PLAT20 : 38 °C


    And ty for your response :)
  4. Tmagic650

    Tmagic650 TS Ambassador Posts: 20,813   +159

    Borrow a PS2 style keyboard and boot into the bios that way. Once in the bios turn off Legacy USB detection. Your razor gaming keyboard should be able to access the bios after doing this
  5. IrishFairy

    IrishFairy TS Rookie Topic Starter

    Ok, now to find someone with a PS2 keyboard in my town
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.