Video Card Problems

By Mentho
Jan 8, 2005
  1. Hi, recently a video card of mine started to get graphical errors so I figured the card was going bad and bought a new one. Untill the new one arrived I put in my old geforce 2 pro, but now when i tried to install my new video card it wont work at all.

    I reseated the card multiple times but to no success, the monitor still remains powered down when I turn on my computer. I've even tried putting my old 9700 pro that was going bad back into the computer and the monitor wont power up for it either. I've disconnected everything but my hard drive and motherboard from the power supply in hopes that maybe I just needed more juice but that doesnt work either.

    Please help if you can, having 1 card work but others not is frustrating and I can't figure out what is wrong.
  2. vega

    vega TS Enthusiast Posts: 147

    Take the memory chips out of the slots and reinstall them - I get a lot of computers with the same problem and reinstalling the memory modules usually does the trick.
  3. Mentho

    Mentho TS Rookie Topic Starter

    I took the ram out and reinstalled it but the cards still dont work. I guess the cards could be bad, but that wouldnt explain why my old 9700 pro wouldnt have worked. It was going bad, but it still started up... just with graphical errors, but now it doesnt start up at all just like the other cards. Im starting to wonder if my motherboard is going bad.
  4. Mentho

    Mentho TS Rookie Topic Starter

    looks like it was my motherboard. went and bought a new one and installed everything and the card worked fine. going to send this old one back to intel, was only 9 months old so should be able to get it replaced.
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...