Video Issue or Something Else?

By EXCellR8
Jun 3, 2008
Topic Status:
Not open for further replies.
  1. Hey guys I've been experiencing a problem with an unknown cause. I have been trying to play Mass Effect on my system but the game keeps acting up. I'm not sure that it "crashes" but the screen will either freeze up or go blank and start flashing as if the monitor is being turned on and off. I can hear the game continuing to run in the background so I'm guessing it's a video issue.

    I'm running a custom-cooled 7950GT which meets the recommended requirements of the game but has been a little buggy in the past. Although the card is relatively fast it's still an AGP and sometimes there are some driver compatibility issues. I haven't had any problems with it for quite some time so it just seems odd that it's acting up now. I am almost wondering if the card is overheating. I do have fan controls on the outside of my case in which I can change the speed of the Zalman copper cooler on the card. I usually turn the fan to max when I am gaming so I didn't really think heat would be an issue.

    I took the card out of the system and there was a lot of dust build-up on the fan. I've since taken care of that and now I am debating whether or not to install new video drivers. I think I might try to run the game again with all that dust removed to see what happens. If I experience the same problem, or similar, should I try new drivers or wait for a possible fix? I've searched around and have come up empty-handed. Any input is appreciated. Thanks in advance.
  2. mailpup

    mailpup TS Special Forces Posts: 8,276   +177

    The game is fairly new so you should install the latest graphics driver. Have you been able to run the game ok before or have you had problems from the beginning? Is this the only game you've had this problem with?
  3. EXCellR8

    EXCellR8 The Conservative Topic Starter Posts: 2,278

    Yea I kinda figured that I should update my drivers since the game is brand new; I've been having this problem from the start. The game is amazing so I'm really anxious to find a solution to this so I can actually play it for more than 20 minutes. Most other games run fine... Stalker, BioShock, UT3, CoD4 and even the newer Source titles run flawlessly. I guess I'll give the new drivers a try and see what happens.
  4. mailpup

    mailpup TS Special Forces Posts: 8,276   +177

    Let us know if the new driver fixed your problem.

    If the new driver doesn't fix the problem, the game might need a patch. Eventually most games come out with patches but it's hard to predict when.
  5. EXCellR8

    EXCellR8 The Conservative Topic Starter Posts: 2,278

    I know this thread is a little old now but I figured I'd give my update/remedy on this problem here. I haven't really had time to test the drivers so I apologize if this seems a little late.

    Anyways, the game seems to be running just fine now. I am currently running ForceWare 175.16 (WHQL) drivers and the latest version of DirectX 9.0c with my 7950GT and all is good. I ran the game for 5+ hours straight without any problems; I think I'm getting better performance too. I've found nothing so far on any similar issues for this game so hopefully this info will prove useful to others.
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.