TechSpot

Vista and Windows Installer problem

By Skutty
Mar 28, 2008
  1. Greetings Techspot.

    This all started with Company of Heroes. Trying to install an updated version of the game failed and produced an error code. According to the developer, the problem can be resolved by updating Windows Installer to version 3.0. But I run Vista, which already has Windows Installer 4.0.
    Vista Service Pack 1 apparently has an updated Windows Installer, but upon beginning installation of the service pack, I am met with another error code: 0x80070005. Microsoft lists multiple ways to fix this.
    Running the System File Checker, which when I attempted to do so, told me I already had a diagnostic service running, and to restart and try again. After restarting, I still get this message.
    Also a memory scan, which completed successfully, no errors.
    Attempting to manually patch Company of Heroes up to the current version doesn't work either. All patches after a certain version (the same version the updated game disk starts at) crash instantly.

    Everything mentioned above works perfectly on my main computer. Both are running Vista Home Premium x64.

    Specs of this computer:
    Athlon 64 3200+
    Gigabyte GA-M55SLI-S4
    1.5GB Corsair 533MHz DDR2
    Radeon X1300 512MB
    80GB HDD
    Vista Home Premium x64

    Help :)
     
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.