Vista says "No disk found" when installing

By Jim333
Dec 6, 2008
  1. Hi,
    I had XP on my computer then, formatted (with a partition) and installed vista,
    But it would only find half of the RAM, so i completly formatted again (no partition) and tried to install Vista again, but when it gets to asking where i want to install Vista it says "No Disk Found" and will not detect the hard drive,

    Do i need to find a driver for the hard disk? Or is it something in BIOS?
    Thanks for any help
  2. Mictlantecuhtli

    Mictlantecuhtli TS Evangelist Posts: 4,345   +11

    Half of how much RAM?

    If you're using a RAID controller or similar that Vista doesn't recognize out of the box, you'll have to load drivers for it first. There should be an option to load drivers in the disk selection screen.
  3. Jim333

    Jim333 TS Rookie Topic Starter

    1gb of ram then it only detected 512mb
  4. Munckis

    Munckis TS Rookie Posts: 18

    You might want to check starting with your BIOS and see if it's fully recognizing the memory there, also while you're there check the settings for the HDD, whether it's set in AHCI, RAID, or IDE modes. If you're not showing the full memory in the BIOS start with re-seating it to see if it comes back. As far as the HDD for the install you'll want the BIOS set so its not in AHCI or RAID mode unless you're actually running a RAID setup.

Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...