TechSpot

Vista usb problems

By bradman666
Sep 10, 2008
  1. Hi, my vista home premium upgraded itself and now I cannot use any usb ports. In device manager I see this...
    [​IMG]

    When I try to update the drivers I see this...
    [​IMG]

    I have tried to delete the file infcache.1 in the windows inf directory but this has not helped. I have also been repeatedly unable to install vista sp1, it goes through the whole process says it has done it successfully restarts and then rolls back the changes. Despite a long chat session with microsoft I can find no way of installing it. Any help really would be appreciated.

    I tried using driver genius too. I installed the intel driver package it recommended but this only got so far and then said it had run into a problem and could not continue. So I reinstalled the back-ups.

    Regards, Matt.
     
  2. fastco

    fastco TS Rookie Posts: 1,511

    That sucks... Have you tried to delete each unknown device, then restart the computer and see if Windows is able to properly install the USB Controllers itself?
     
  3. bradman666

    bradman666 TS Rookie Topic Starter Posts: 24

    Sorted it out

    Well I found that if I uninstalled all these then it was able to reinstall them all properly. Weird. I hope this helps someone else.
    Matt.
     
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.