TechSpot

VLC media player not in autoplay options

By Elliah
Sep 23, 2008
  1. when i load a dvd on my laptop running windows vista sp1, the options given do not include vlc media player...i cannot locate vlc media player from autoplay options in the control panel either...i want vlc to autoplay my dvd..how do i do that?
     
  2. tw0rld

    tw0rld TS Maniac Posts: 609   +6

  3. Elliah

    Elliah TS Enthusiast Topic Starter Posts: 118

    does this work for vista?
     
  4. tw0rld

    tw0rld TS Maniac Posts: 609   +6

  5. codam

    codam TS Rookie

    I had the same problem and used this site to fix it:

    www . schlackman . org/programs/vlcxp.html

    [remove spaces, it wouldn't let me post a link]

    This worked but the dvd menus weren't working completely perfectly, so I changed the .reg file slightly, by removing the @0:1 from this line

    [HKEY_CLASSES_ROOT\VideoLAN.Autorun\shell\playdvd\command]
    @="\"vlc.exe\" -vvv dvd://%1@0:1"

    and now it all works fine.
     
  6. j707

    j707 TS Rookie

    This doesn't work with Vista x64. The registry addition installed correctly, and I removed the @0:1 as instructed, but VLC still does not appear in the AutoPlay options dropdown.
     
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.