TechSpot

Web Cam Driver missing or corrupted

By reka1052000
Sep 11, 2008
  1. Hi...

    My laptpo Dell inspiron 1420, has integrated webcam but it didnt work. in device manager it said that "windows cannot load the driver. driver missing or corrupted (code 39)". I've alredy tried to resolve using microsoft help and support way but the problem persist. so pls anyone help me how to solve it .....

    regards....
     
  2. kimsland

    kimsland Ex-TechSpotter Posts: 18,353

  3. reka1052000

    reka1052000 TS Rookie Topic Starter

    Pardon me,

    Im beginner in computer, as u gave me link to that dell support explain me what should i go and do for that link.
     
  4. kimsland

    kimsland Ex-TechSpotter Posts: 18,353

  5. reka1052000

    reka1052000 TS Rookie Topic Starter

    I ve alredy done your instruction, i downloaded the driver and run that driver but still my prob persisted. "Windows cannot load the device driver for this hardware. The driver may be corrupted or missing. (Code 39)". so what should i do next?

    thnx for your guidance
     
  6. CCT

    CCT TS Evangelist Posts: 3,556

    In Device Manager, select that device and the driver and click 'uninstall'.

    The install the NEW driver and reboot.
     
  7. reka1052000

    reka1052000 TS Rookie Topic Starter

    yes i did it unintall webcam from device manager then reboot. but still camera not working and same message in properties "driver corrupted". any idea?
     
  8. kimsland

    kimsland Ex-TechSpotter Posts: 18,353

    driver corrupted means the downloaded driver is corrupt
    You would need to download again (preferably direct link above)

    I'm wondering also, if there is a disable webcam in bios issue here, it could also be a disabled service in services.msc (not sure which one just now, but that's it, for possibilities)
     
  9. CCT

    CCT TS Evangelist Posts: 3,556

    See if the camera drivers are listed under Control Panel, Programs and Features.

    If so, delete them.

    Like kimsland said, delete that downloaded driver executable and try again. Make sure you delete/uninstall any camera drivers that are there.

    Then reboot, install the new drivers (to a folder if you can called Camera).

    gl
     
  10. reka1052000

    reka1052000 TS Rookie Topic Starter

    yes i did as u both said. but still no progress. this problem keep existing
    plz guide me if any other idea
     
  11. CCT

    CCT TS Evangelist Posts: 3,556

    So, you created a new Folder called Camera and have put the drivers there? Is there a file with a .inf extension in that folder?
     
     
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.