TechSpot

Websites loading slow/PC slow

By scmcginley
Sep 24, 2008
  1. My PC has suddenly started running slow. Various websites and webpages open extremely slow or time out after about five minutes. Also, downloading files has also slowed down and takes a much longer time than it use to. Even accessing this forum to post took awhile.

    It seems that my entire PC is all of a sudden slow, as if the resources are being sucked up somewhere. My internet connection/speed has been checked through my provider (Charter) and it is working correctly.

    Can anyone suggest wheat I can do to speed it up again? Any help would be appreciated.

    I attached a recent hijack log if that helps.
     
  2. kimsland

    kimsland Ex-TechSpotter Posts: 18,353

    With all this starting (and more) I'm not surprised
    Symantec
    Norton Ghost
    Ad-Aware
    Spy Sweeper
    Dell Media Experience
    iTunes
    Hewlett-Packard Digital Imaging
    iPodService.exe
    WINWORD.EXE

    Run Startup Control Panel, and untick all non-essential startups
    Contemplate removing Symantec Antivirus (just a resource hog)
    And try a Free Antivirus like Avast or Avira
    And lastly run CCleaner

    Then venture over to the New Preliminary Removal Instructions

    I'd say all would be good then
     
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.