TechSpot

Why my USB flash drive works only on some computers but not others?

By tourmaline
Dec 8, 2015
Post New Reply
  1. Hi

    I have recently purchased a 64GB USB 2.0 flash drive. It works fine on my desktop PC (I tried on different USB ports). However, my Windows 10 tablet can't recognize it (USB light keeps blinking, but device not shown up in file explorer/Disk management/Device manager). I then tried it on my work PC (Windows 7), USB light is on (not blinking this time), but the device is not recognized either ( no error, just nothing happens). I tested my Windows 10 tablet's USB port and work PC's USB port with other USB devices, and they worked well, so it does not look that there is any problem with my USB ports... very weird issue. Anyone has any clue that what could have gone wrong with the USB flash drive?
     
  2. Cycloid Torus

    Cycloid Torus TS Evangelist Posts: 1,657   +309

    Probably wrong, but I wonder if the file system is known to the Win10 tablet. My flashdrive is exFAT and other possibilities are FAT32 and NTFS. Someone smarter than I might know more about tablets and file systems.
     
  3. tourmaline

    tourmaline TS Rookie Topic Starter

    The 64GB USB flash drive is FAT32. My work PC (which is Windows 7) also does not recognize it. But it works well on my home PC (win 7) and works no problem when I plug it into the USB port of my multimedia player. My Tablet is a Win 10 tablet, so it should work just same as a windows 10 laptop... and I tested other USB flash drive/wireless mouse with the WIN 10 tablet, no problem at all.
     
  4. Cycloid Torus

    Cycloid Torus TS Evangelist Posts: 1,657   +309

    Since it works in one Win7 machine, but not another, I am beginning to think something about the flash drive is 'out of specification' or defective. I have read of some cases where the contacts in flash drive were not long enough to make full contact. You may want to return the one you have.
     
  5. tourmaline

    tourmaline TS Rookie Topic Starter

    Yeah, that's my suspicion too.... unfortunately it has passed the 30 days return window... because it worked on my home PC and multimedia player, so I never thought it would not work on other PCs... and I always thought USB flash drive should just either work or not work... oh well, a lesson learned. But interestingly my home pc's USB port, monitor's extended USB port and avi player's USB port can support it but not the other PCs. So I guess the USB ports are not that standard either... Next time when I buy a USB stick, I will have to test it on all my devices then...
     
  6. jobeard

    jobeard TS Ambassador Posts: 9,319   +618

    The issue is Win/8 or /10 related but I've not cracked the issue as I don't have access to either. The flash drive is just fine as FAT32, exFat or vFat.

    I've seen that if one makes Win/10 access the flash, then Win/7 systems can not any longer, so that indicates Win/10 is altering the partition details.
     
  7. Cycloid Torus

    Cycloid Torus TS Evangelist Posts: 1,657   +309

    You might have it... seems like some other folks were having trouble with Win10 changing properties of files... this thread might help:
    http://www.cnet.com/forums/discussions/windows-10-changed-all-my-documents-to-read-only/
     
    Last edited: Dec 9, 2015
  8. jobeard

    jobeard TS Ambassador Posts: 9,319   +618

    Here's the Windows HOT-TO for taking Ownership.

    Pay attention here:
    • for a flash drive, access the drive letter pointing to the drive, get the properties, click Security tab, add the EVERYONE group and give it FULL Control.

    • for a hard drive, access %USERPROFILE%, get properties, click Security tab. Your login name should already be shown in the top half. Click on it and the bottom half should have FULL CONTROL, if not make it so
     

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...