TechSpot

Windows 7 Print Spooler stop/start

By everest63
Dec 8, 2010
Post New Reply
  1. Hi, new to the forum. At work we have just gotten 4 new laptops that have Windows 7 Professional. One of our users had a Vista laptop that always had the print spooler stop when he tried to print. I had to go into the services and start the print spooler again. When trying to print a second time the message would pop up again to state that the Print spooler had stopped. I hoped that the Print Spooler issue with Vista would be cured in Windows 7. Well, sort of. With the 4 new Windows 7 laptops that I have setup onto our domain I notice that the Print Spooler takes about 2-3 minutes to start. We have a print server in our domain and all the shared printers will not show up in the OS until the Print Spooler service starts up. I checked the dependencies of the Print Spooler Service and it is the Remote Procedure Call. That service does not seem to be an issue. When I try to print to a network printer it takes a long time to print. I check the printer queue and I see two files; the doc and a file called Local Downlevel Document. I try printing an hour later again and I can print with no issues. Then I will try to print again the Print Spooler service will stop and I will have to restart it. I searched the net and I see tons of hits for Windows 7 Print Spooler issues and I have tried a lot of fixes but I still have issues. I even installed a Win 7 driver for two of the printers, one local (LJ5) and one networked and the local printer never has an issue! Possibly it is a domain issue or an issue with our print server? We have two division offices in CT and NJ and they are in the same domain ( but different DC and print server) and the IT guys there said they have no Print Spooler service issues with their Win 7 laptops. Pulling my hair out here though, LOL.
    I run this script as a batch file and it helps sometimes but not all.
    @echo off
    echo.
    echo Purging the print queue . . .
    net stop Spooler
    echo Deleting all print jobs. . .
    ping localhost -n 4 > nul
    del /q %SystemRoot%\system32\spool\printers\*.*
    net start Spooler
    echo Done!
    ping localhost -n 4 > nul


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.