TechSpot

Windows 7 won't boot, even in safe mode - aswrvrt.sys

By infinityatlas
May 13, 2013
Post New Reply
  1. After downloading an avast update
    proceeded to restart, after that while starting windows, it would reach the windows logo and blue screen.
    repeated that a few times.

    After that booted in safe mode....
    safe mode
    safe mode with networking
    safe mode with cmd prompt

    booting with these causes it to load the windows files, then it gets to aswrvrt.sys
    it then pauses for 15 secounds before blue screening again

    tried system repair from f8, only shows pointer, does not load at all
    tried system repair from disk, lets me select the keyboard input, after that same thing happens as f8

    Really don't want to lose any files, been searching everywhere for a fix, help!

    thanks

    Also tried restoring from last restore point or w.e ...
    doesnt work either
     
  2. Tmagic650

    Tmagic650 TS Ambassador Posts: 20,987   +168

    What version of Windows are you running?
     
  3. anpepcc

    anpepcc TS Rookie

    I think it's a problem with Avast. If you're able to access the system, uninstall Avast; if not, try a Linux live CD and type the following in a terminal:

    $ sudo su
    # mkdir /mnt
    # mount /dev/sda /mnt
    # cd /mnt
    # rm Windows/system32/drivers/aswrvrt.sys
    # rm -rf "Program Files/Avast!"
    # reboot

    After reboot, Windows should boot properly.
     


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.