TechSpot

Windows Pro SP3 black screen on start up

By terry5880
Apr 18, 2012
Post New Reply
  1. hi all i got pc with win pro sp3 and when i turn it on i get black screen saying NTLDR is missing press ctrl alt delete to restart but thats all it does is restart then back to same thing please help as i do not want to reformat as i will lose everything . but if this is only way then is there anyway to save my photos applications etc thanks in advance
  2. terry5880

    terry5880 TS Enthusiast Topic Starter Posts: 527

    hi found compaq recovery disc so tried a press r for recovery its done but now still blk screen but msg now says NTLDR is compressed help help i dont want to do full reformat as will lose everything
  3. terry5880

    terry5880 TS Enthusiast Topic Starter Posts: 527

    hi all update i now have managed to get windows logo screen up but now get msg saying
    "your system has detected a configuration error, please report this error to customer care using the phone number found in the warranty and support guide that came with you PC. Unless corrected, this error will prevent your PC from operating properly. Turn off your PC by pressing and holding the power button. After a few seconds your PC will automatically turn off. (Code Purple)

    I see a thread on here with same problem from 2008 and the guy managed to fix it thanks to a member called simon boss here is what simon put
    To access the "C:" drive to rename the file:
    1. Boot the system with a Win Xp Original Disk.
    2. When you have to select "Enter" to reload or "R 'for Recovery Console select" R ".
    3. Select the "C: \ minint" Drive to bring up the System
    4. At the "H:\minint" prompt, change to the "C:" prompt
    5. Change to the directory "C: \ hp \ bin \ configcheck"
    6. Rename the file with the command "ren run.py run.p_"
    7. Reboot the machine and there should be no "Code Purple" error.

    i get to number 3 and am confused can someone pls help thanks
  4. terry5880

    terry5880 TS Enthusiast Topic Starter Posts: 527

    think i worked it out but still gets to windows screen and same message please some one help asap
  5. Tmagic650

    Tmagic650 TS Ambassador Posts: 20,832   +164

  6. terry5880

    terry5880 TS Enthusiast Topic Starter Posts: 527

    hi magic i cant get into pc tho it gets to windows logo screen but then freezes on that with msg about purple code so only thing i can do it restart over and over
  7. Tmagic650

    Tmagic650 TS Ambassador Posts: 20,832   +164

    Get another hard drive. Install Windows on it and then transfer the data you want, from the "bad" drive to the good one
    terry5880 likes this.
  8. terry5880

    terry5880 TS Enthusiast Topic Starter Posts: 527

    i see what your saying m8 put as 2nd drive slave and copy all to that then do fresh install would that work with an external harddrive aswell ?
  9. Tmagic650

    Tmagic650 TS Ambassador Posts: 20,832   +164

    Yes it will...
    terry5880 likes this.
  10. terry5880

    terry5880 TS Enthusiast Topic Starter Posts: 527

    ok buud thanks i just found a 500gb internal 7200rpm £60 is that good bud
  11. Tmagic650

    Tmagic650 TS Ambassador Posts: 20,832   +164

    Yes that will be fine
    terry5880 likes this.
     
  12. terry5880

    terry5880 TS Enthusiast Topic Starter Posts: 527

    ok bud so i take out old drive put new 1 in install windows on it then once all good put old drive in as a secondary . so if im right main will be (c) old 1 will now be (d) then copy all my stuff from " (d) " to " (c) " once done then bingo. then just use old drive as a storage ?
  13. Tmagic650

    Tmagic650 TS Ambassador Posts: 20,832   +164

    That sounds like a good plan. Just take your time, and good luck
    terry5880 likes this.
  14. terry5880

    terry5880 TS Enthusiast Topic Starter Posts: 527

    tmagic650 the 1 of 3 pll who seem to reply to people thanks so much for your help and quick replys bud LEGEND
  15. Tmagic650

    Tmagic650 TS Ambassador Posts: 20,832   +164

    I am here in my home office, at least 12 hours a day. While I am waiting for parts or computers to finish updating, I have a computer right here to answer posts, that's why I am fast. The new site took a few days to get used to, and I was out of town last weekend


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.