Windows runs CheckDisk at every startup?

By magaman598
Jun 25, 2010
  1. Hello everyone and thanks ahead of time.

    This all started happening after recieveing a DOA Corsair HX650W Modular PSU. (was only puttin out 10.6V on the +12V Rail.) So I got a unit Cross-shipped and got everything put back together and Windows thinks it needs to run a Check disc at startup, but the funny thing is that it's not even being ran on my 160GB drive, it's being ran on my 1TB drive that I use for storage and backups, Any ideas at all?

    I'm currently looking for Western Digital's software stuffs for testing purposes.
  2. magaman598

    magaman598 TS Booster Topic Starter Posts: 188

    Found it, I'm running a full diagnostics on the 1TB Drive right now. 2:20:43 test...
  3. raybay

    raybay TS Evangelist Posts: 7,241   +9

    You might want to run ChkDsk with guided help... that will allow you to test both drives, and whatever.
    to better check both hard disk for errors.
    Be aware that the actions that this Microsoft Guided Help performs cannot be undone after Guided Help is finished. For more information, click the following article number to view the article in the Microsoft Knowledge Base: 915092 ( )

    - You must be logged on to Windows by using a computer administrator account to install and to use this Guided Help.
    - You must be running Windows XP Home Edition, Windows XP Professional, Windows XP Media Center Edition, or Windows XP Tablet PC Edition.
    - You must first download Guided Help from

    And of course, it is probably nothing. And the Western Digital diagnostic software is good.
  4. magaman598

    magaman598 TS Booster Topic Starter Posts: 188

    Alrighty, before I do anything else I'm going to wait for this to finish tho. :zzz:

    The interface for Western Digital's sfware is actually pretty nice, I wish all software was like this. *cough*AMD Overdrive*cough*
  5. raybay

    raybay TS Evangelist Posts: 7,241   +9

    No need to run the ChkDsk once you have run the Western Digital software, except to turn off the message you have been getting.
  6. magaman598

    magaman598 TS Booster Topic Starter Posts: 188

    I don't get a message, it does it while Windows is booting. -_-

    Sorry if I was a bit unclear in my first post.
  7. raybay

    raybay TS Evangelist Posts: 7,241   +9

    That is what it wants done... Run ChkDsk upon reboot.
  8. magaman598

    magaman598 TS Booster Topic Starter Posts: 188

    Anyway I could possibly keep it from running Check disc?
  9. jobeard

    jobeard TS Ambassador Posts: 9,160   +599

    try booting into Save Mode and running CHKDSK /F from there.

    The constant rerunning says it has never complete a total pass over the HD.
    Once that can be completed, it will stop rescheduling itself
  10. raybay

    raybay TS Evangelist Posts: 7,241   +9

    Yes, but it is some trouble, and if wise, you would go back to change this later.
    The first choice is to run ChkDsk again until it has completed a full ChkDsk. Otherwise, you do this:
    Those folks at Microsoft didn’t make it easy, because Microsoft doesn’t want you doing this, as you may need ChkDsk sometime. But as long as you don’t type entries incorrectly, you are ok. You can edit your registry if you are skilled or even just familiar with registry entries.
    Or you can use the /x switch to exclude the drive(s) from the default boot-time check that is irritating you. IN THE COMMAND PROMPT, if you use C:/ as your hard drive, then the command to disable CHKDSK is chkntfs /x c: If you have two drives, such as C and M, you can disable them with the command chkntfs /x c: m:
    The chkntfs is a utility that works by modifying the BootExecute value in the registry. It is located in this registry key: HKEY_LOCAL_MACHINE\SYSTEM\CURRENTCONTROLSET\CONTROL\Session Manager.
    Your default value for BootExecuter would be autocheck autochk *. when you use the /x switch, you will add a /k parameter prior to the asterisk. The /k parameter excludes volumes from being checked for the presence of a dirty bit.
    For example, if you run the command chkntfs /x c: in command prompt. This command would modify this registry entry to autocheck autochk /k:c *.

    Remember to change it back later to make sure your computer functioning is good and safe… because you may not remember this later.
  11. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +183

    I concur with jobeard. Boot into Safemode (or just boot directly into recovery console) to run chkdsk /f manually and let it run to completion.

    If the problem persists see this MS KB
  12. magaman598

    magaman598 TS Booster Topic Starter Posts: 188

    But everytime it boots I let it do the pass, and it's fairly quick.

    Also, the 1TB Drive passed Western Digitals testing stuffs..

    Also, my apologies for the long awaited reply, I put my daughter down for a nap and ended up taking one with her. lol :haha::zzz::grinthumb
  13. jobeard

    jobeard TS Ambassador Posts: 9,160   +599

    hmm; 1TB and a quick return????? Some concern there!
    Are you checking the right drive?
  14. magaman598

    magaman598 TS Booster Topic Starter Posts: 188

    Yea, it says the Lable for the Drive is "Everything else" and that's the name of my 1 TB.

    It passed Western Digital's testing stuffs with flying colors tho. I'm a bit puzzled myself.
  15. jobeard

    jobeard TS Ambassador Posts: 9,160   +599

    try a different option
    chkdsk dla /r
    where DLA is the Drive letter of the 1tb
  16. jobeard

    jobeard TS Ambassador Posts: 9,160   +599

    or even chkdsk c: /f /r
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...