Windows update

By kpbradley
Jun 12, 2008
  1. I am running Windows xp pro sp 3 and I can not get any up date now it keeps telling me to check the following

    [Error number: 0x8DDD0018]
    The site cannot continue because one or more of these Windows services is not running:

    Automatic Updates (allows the site to find, download and install high-priority updates for your computer)
    Background Intelligent Transfer Service (BITS) (helps updates download more quickly and without problems if the download process is interrupted)
    Event Log (keeps a record of updating activities to help with troubleshooting, if needed)
    To make sure these services are running:
    1. Click Start, and then click Run.
    2. Type services.msc and then click OK.
    3. In the list of services, double-click on Automatic Updates and then click Properties.
    4. In the Startup type list, select Automatic and click Apply.
    5. Verify that the Service status is started, if the Service Status is Stopped click on the Start Button.
    6. In the list of services, double-click on Background Intelligent Transfer Service (BITS) and then click Properties.
    7. In the Startup type list, select Manual and click Apply.
    8. Verify that the Service status is started, If the Service Status is Stopped click on the Start Button.
    9. In the list of services, double-click on Event Log and then click Properties.
    10. In the Startup type list, select Automatic and click Apply.
    11. Verify that the Service status is started, If the Service Status is Stopped click on the Start Button.
    If this does not resolve the problem you may request help from one of the following resources.

    I check everything and it will not allow me to change step 3, it just keeps changing it back to disabled.

    Any help with this issue...
  2. gbhall

    gbhall TechSpot Chancellor Posts: 2,423   +77

    Possibly you have turned off automatic updates entirely (as I do). Open control panel, click security centre and the automatic updates link options will probably have 'turn off automatic updates' selected. Turn this on temporarily while you do your monthly 'patch Tuesday' updates and turn it off again afterwards.

    Failure to do this can result in downloading from MS all sorts of things of no use at all, inclusing SP3 which most people do not need and has caused considerable grief to many, many around the world - especially those with AMD processors and running specific software (even including MS own software such as SQL server and Dynamics suite. Will they ever get things right first pigs fly??

    Many experts recommend not installing a service pack (as opposed to a patch) for at least 3 months after issue. There is also suggestion from some quarters that MS are using the SP3 to install additional WGA software to bring XP up to the same level of anti-****** checks as Vista. This is a very, very, very bad idea, not just because in the great scheme of things MS is being ripped off to a significant degree, oh no, but because it is just a piece of software, and can be hacked by nasties in such a way that people will (in my expectation), suddenly be confronted with messages 'your PC is running illegal software and will not be usable from today'. Even though they have NO illegal software.....
  3. Bobbye

    Bobbye Helper on the Fringe Posts: 16,335   +36

    I would first suggest that you uninstall SP3 in Add/Remove Programs in the Control Panel.

    Then I suggest you change the update mode to either 'download but don't install' or 'don't download or install, notify me'. Then using the Custom function(instead of Express) check each update- see if you want it, need it or if it's appropriate fro what's on your system, then install.

    But if you want to remain in the group that allows Microsoft to put everything on your system automatically> run this command from a command
    prompt: regsvr32.exe wuaueng.dll

    After running this, set Automatic Updates to Automatic. BITS will also need to be running. Reboot the computer and get the updates.

    However, i am in complete agreement with this:
  4. zipperman

    zipperman TS Rookie Posts: 1,179   +7

    What i do

    Mine is disabled.I use the Start Menu
    Windows Update when i choose to..
    Settle for that as something else may be
    running to stop the update check at that time.
    Shut everything down first.
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...