TechSpot

Windows XP BSOD, Minidump help

By gbirk
May 6, 2008
  1. I have been having a heck of a time figuring out why I am getting a "random" BSOD. It is a Lenovo t60 laptop with XP Pro SP2. I have run the Lenovo System Update several times and everything is current (This includes drivers and BIOS I believe). I ran Memtest for 48 hrs straight with no errors. I have 2Gb of ram (two 1Gb chips) and I have run with each chip seperately and still get the errors. Did a full reinstall from factory disks, and have ran chkdisk and Spinrite several times with no errors. I have posted the minidumps to callforsupport.com/minidump and was hoping some kind soul could look at them and point me in the correct direction to get this fixed.

    Thanks in advance.

    Geoff
     
  2. kimsland

    kimsland Ex-TechSpotter Posts: 14,524

    And what have they suggested?
    By the way is that service costing you money?
     
  3. gbirk

    gbirk TS Rookie Topic Starter

    Well, "they" are ( or is it is) "me" if that makes sense. I own that domain, and posted the files there to make them available to others should they wish to see them.

    I have looked at the minidump files with WinDbg and below is what looks important to me:

    MiniDump 1:
    BugCheck 1000008E, {c0000005, 8054a0ba, ef1ca5dc, 0}
    Probably caused by : Pool_Corruption ( nt!ExDeferredFreePool+b4 )
    Followup: Pool_corruption
    KERNEL_MODE_EXCEPTION_NOT_HANDLED_M (1000008e)
    PROCESS_NAME: svchost.exe
    IMAGE_NAME: Pool_Corruption

    Minidump 2:
    BugCheck 1000008E, {c0000005, 8054a168, eee3683c, 0}
    Probably caused by : Pool_Corruption ( nt!ExDeferredFreePool+162 )
    Followup: Pool_corruption
    KERNEL_MODE_EXCEPTION_NOT_HANDLED_M (1000008e)
    PROCESS_NAME: bmctl.exe
    IMAGE_NAME: Pool_Corruption

    Minidump 3:
    BugCheck 1000008E, {c0000005, 805a33d6, ee63fc18, 0}
    Probably caused by : ntkrpamp.exe ( nt!NtAcceptConnectPort+18c )
    Followup: MachineOwner
    KERNEL_MODE_EXCEPTION_NOT_HANDLED_M (1000008e)
    PROCESS_NAME: svchost.exe
    IMAGE_NAME: ntkrpamp.exe

    Minidump 4:
    BugCheck 19, {20, e35f543b, e35f577b, c684704}
    Probably caused by : ntkrpamp.exe ( nt!ExFreePoolWithTag+2a3 )
    Followup: MachineOwner
    BAD_POOL_HEADER (19)
    PROCESS_NAME: iexplore.exe
    IMAGE_NAME: ntkrpamp.exe

    Minidump 5:
    BugCheck 10000050, {8e7000a8, 0, 805badb7, 0}
    Probably caused by : ntkrpamp.exe ( nt!ObpCloseHandleTableEntry+13 )
    Followup: MachineOwner
    PROCESS_NAME: services.exe
    IMAGE_NAME: ntkrpamp.exe

    I have Googled ntkrpamp.exe and the consensus seems to be that it is a driver problem, but how do I find what driver to remove/update?

    Bad memory is also an option, but I have tried running with only one of the two chips installed, the swapped them around to see if the problem would go away, but it did not. Also, Memtest has run for days with no errors.
     
  4. kimsland

    kimsland Ex-TechSpotter Posts: 14,524

    All of them, usually.

    Go to your manufactures website, and download all the latest drivers.

    Also, one user reported that putting his video memory in CMOS to 65Meg fixed it.

    You should also do all your MS security updates.
     
  5. gbirk

    gbirk TS Rookie Topic Starter

    I have already updated all of the drivers, and the BIOS. I will try the video memory change and see what happens.

    Thanks.
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...