Windows XP only shows 2.87GB of RAM? Even on x64?

By Lovepotion69
Sep 14, 2009
  1. I recently built a computer using an Intel D915PBL mobo and a 3.0ghz P4 w/ HT processor (lga 775). I put 4gbs of RAM in there the first time and I installed WinXP SP3 (x32). It was only showing on the My Computer properties that I had only 2.87gbs? I know that I saw the bios read the 4gbs so I know my ram is working. I did a little reaserch and ppl kept saying that x64 OS's showed the 4gbs. So, I tried installing WinXP SP2 (x64). I did a fresh install by booting the disk 4rm the bios and installing the new XP on top of the hard drive that had the old Xp thus reformatting the hd and giving WinXP x64 a fresh installation. Guess what? It still only shows 2.87gbs of RAM on the My Computer properties. I don't know what to do anymore. Anyone know HOW to fix this? Thnx 4 reading.
  2. MaXtor

    MaXtor TS Booster Posts: 101

    I'm guessing you use onboard graphics? That's likely where your ram is going, you should be able to configure how much goes to your onboard graphics through your bios.
  3. jtickner1

    jtickner1 TechSpot Chancellor Posts: 650

    If you look up the board he said he's using it says that it has no on-board video. The only thing I can think off is to take one stick of RAM out and boot into Windows and see how much it reports, then try again. Although, if it's broken I don't know what the chances are of it mis-reporting in Windows.
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...