TechSpot

Wired to modem works, but wired to router does not

By tom4u
Dec 28, 2008
  1. Hi all,

    I have an Aztech ADSL 2/2+ modem and a Dlink DGL4300 wireless router.

    I set up my modem and when wired to my pc, it works.
    I followed the manual to install the wireless router, so that my pc is now connected to the wireless router, but somehow I'm not able to get the internet.

    It works again when i replug my pc direct to the modem.

    Can any1 help me please?

    I set up my wireless router to connect to internet via PPPoE, settings are fine. do i need to reset anything and in any particular order?

    Thanks,

    Tom
     
  2. jobeard

    jobeard TS Ambassador Posts: 9,322   +622

    The modem has the PPPoE connection; Your wireless connection to the router should be straight ethernet
     
  3. tom4u

    tom4u TS Rookie Topic Starter

    hi,

    my connection is phone line > modem > wireless router > via ethernet to pc.

    This is to set up only. Ultimately, I wish to unplug the PC and shift it to another location. Both modem and router have been setup for PPPoE connection, just that the above connection does not work.

    if phone line > modem > pc, it works fine.

    the problem is my power adapter for the router fried, so the router resetted to factory settings after i got a spare adapter. i need to set up the connection over again. the phone line > modem > wireless router > via wireless to pc worked fine before, and i am following the same instructions again to set up.
     
  4. tom4u

    tom4u TS Rookie Topic Starter

    what happens if i want my router to automatically reconnect everything a connection is dropped?

    my ADSL modem is PPPoE connection.

    When i reset my router, it changes to DHCP.
    But if i want my router to auto reconnect, I remembered I set it to PPPoE as well, and always connect.

    Once I changed to this setup, it does not work after I saved settings in the router...
     
  5. tom4u

    tom4u TS Rookie Topic Starter

    duh, i figured out the problem anyway.
     
  6. jobeard

    jobeard TS Ambassador Posts: 9,322   +622

    good :) Please share your findings to assist the next reader :wave:
     
  7. tom4u

    tom4u TS Rookie Topic Starter

    oh right.

    Just dont set up the ADSL modem to connect.
    I had the modem set up to PPPoE connection, but did not connect.

    I then set up my wireless router to PPPoE connection, and connect from there. Internet access was available soon after.

    I think because the ADSL modem was previously connected to internet, so when my router tried to connect, it couldnt do so. Therefore, I'm not able to get internet access via my router (UNLESS the router is using DHCP instead of PPPoE)

    Most wireless router manuals would have informed the user for a PPPoE connection, the user has to set the modem to bridge mode and router as router mode if you intend to connect via router. Just dont ask your modem to connect to internet.
     
  8. jobeard

    jobeard TS Ambassador Posts: 9,322   +622

    ADSL PPPoE connections

    Interesting; Almost everyone is using the PPPoE at the modem and doing the connection from there.

    The important point you discovered is:
    The ISP connection can only be performed once: (a) at the modem or (b) at the router :)
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...