Wireless Adapter problems USB/power failures?

By glowingnissan07
Aug 22, 2008
Topic Status:
Not open for further replies.
  1. Hey everyone. I feel like my computer is having some serious problems, or will be very soon.


    Its with my internet. Our home has a lynksys router, im not sure wat kind, but a damn good one, and i bought a Belkin N Wireless network adapter for my PC. Its been working hitch free for a long time, other than that fact i am quite far from the router and have low signal strength in my home network. I get really fast download speeds, and great latency for gaming. Recently however, ive been getting a lot of hitches with my internet adapter.

    Often times, the windows will make that "USB out" sound almost randomly, and I disconnect from the net, even though my adapter is plugged in and recieving power. IT will often do this several times in a row. Or, it will connect to the internet, then lose the connection but stay connected to the network, then try and reconnect to the internet and keep repeating over and over again (as shown on the Belkin utility program thats alaways running). At some points it will lose the connection completely. I would've said that justs sounds like an adapter too far from the router, but the other thing is sometimes the power light on the thing would give out and stay out, and id have to replug it back into the USB port to try to start it up again, or disable/enable it in Device Manager. Its never done that before.

    The other wierd thing is, when i replug it, i get this little message from windows saying that my USB Device can perform much faster in a USB hi speed port. I've tried every USB port on my PC, and even removed all other USB devices except my mouse, but this message will randomly pop up regardless of the port. Its never done this before, its always worked fine.

    Typically, when the thing is connecting to the network, the power light blinks repeatedly for a few seconds. But when I get that little error message saying it can peform faster, i notice the light blinking A LOT slower than it should be.

    Sometimes Windows wont recognize it, or it say it didnt connect properly. Im not sure wats going on but it almost sounds like a power issue. I'm not sure wat to make of it. Suggestions? (I cant say for sure, but it almost seemed to start doing this when i updated my PC a few nights ago via Automatic Updates, something i have been neglecting for some time)

    Could anything draining power from the USB ports? The only thing i could imagine is my Radeon 9200 vidcard, which has been having some bad issues as well.

    Keep in mind it doesnt ALWAYS do this, sometimes itll connect and work fine. But i gotta hassle through 15 minutes to get it to stay connected.

    Suggestions welcome
  2. Tmagic650

    Tmagic650 TS Ambassador Posts: 20,450   +135

    Your computers power supply may be too weak for it's load demand now
  3. radnam

    radnam Newcomer, in training Posts: 53

    Hello,

    Have you checked if this happens when you are not connected to the power socket.

    Because this might be due to that as well.

    For more help i think this thread would be helpful

    Click here
  4. jobeard

    jobeard TS Ambassador Posts: 13,011   +219

    >> Belkin N Wireless network adapter

    too bad; the -N spec is unofficial and each vendor does it 'their own way'
    (see this post)

    1- update your router firmware
    2- force the router into G-only mode
    3- update the WiFi driver

    see this information on USB Power limitations
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.