TechSpot

Wireless reads but cannot connect to network... is it drivers?

By tm5rto
Jun 30, 2012
Post New Reply
  1. Hi all! Please help! My wife's notebook, (ASUS G71GX, Win 7, wireless card Atheros AR928X), wireless connection to our home LAN (D-Link DIR-655) suddenly stopped. It shows the available networks, but cannot connect to it. The hardware manager shows no problem with the wireless card.

    I'm not sure what the problem is, but could it be the drivers, not the hardware? So far, I uninstalled and re-installed the driver for the AR928X. No changes, but maybe I didn't do it right.

    Could someone help out, please?
     
  2. tm5rto

    tm5rto TS Rookie Topic Starter Posts: 86

    Never mind. Thanks. I ended up deleting my home network, and then re-creating it. That solved the problem, even though I still do not understand how that worked :)
     
  3. jobeard

    jobeard TS Ambassador Posts: 13,450   +324

    BRAVO! Well done - - this is so typical if WiFi connection issues; just recreated the connection and it works again
     
  4. tm5rto

    tm5rto TS Rookie Topic Starter Posts: 86

    Thanks! I wish I knew it was that easy four days ago! Live and learn :)
     
  5. ComputerGuy55

    ComputerGuy55 TS Maniac Posts: 530

    Yeah sometimes issues can be that simple. Possibly the network had a slight change (Encryption type, channel, something) and the old connection settings weren't matching.. Deleting and re-adding can resolve the issue.
     


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.