TechSpot

WoW says "failed to find suitable display device exiting program" when I try to play

By MarlJenkins
Jan 31, 2010
  1. my computer is put together from like a couple other computers but it runs internet and everything fine.
    i just put a new graphics card in it but dont have the disk to install it.
    when i have the card in the computer prior to turning on the computer the computer will turn on but nothing gets sent to the monitor unless the graphics card is out of the computer when i turn it on and put it in afterwards. the card gets power to it and everything but dont seem to be working.

    if anyone can help me that would be super! i miss playing wow THANKS
     
  2. Ididmyc600

    Ididmyc600 TechSpot Chancellor Posts: 2,251

    Hi

    you answered your own question, you need the drivers for the card.
     
  3. mailpup

    mailpup TS Special Forces Posts: 8,484   +233

    You don't need a disk. Even if you had one, it would likely be out of date anyway. Go to the graphic card manufacturer's website, download the appropriate driver and install it.
     
  4. Xecutor

    Xecutor TS Rookie Posts: 141

    What ^^^^ they ^^^^ said. What is the make of your videocard, btw? Nvidia or AMD?
     
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.