WRT54G gives IP address thru wired but not wireless

By RianShelAbbe
Oct 23, 2005
Topic Status:
Not open for further replies.
  1. Another WRT54G problem:

    My WRT54G hands out an IP address to my laptop when the laptop is connected via wired to the router, but the laptop's wirless NIC cannot receive an IP address from the router (XP eventually hands it an APIPA address). Signal strength is excellent but have limited/no connectivity. Linksys email support told me the problem was obviously with the laptop settings. I suspect the drivers for the laptop's NIC, but I'm having trouble updating them.

    Here's what I have:
    -Compaq nc8000, NIC = HP WLAN W500, driver date = 4/18/04
    -WRT54G Firmware = V3.03.9 Apr 27, 2005
    -I've attempted changing channels but the same problem

    Through HP's site, I downloaded the Intel PRO/Wireless Driver SP31172.exe V4F (Sept 16, 2005). Followed the instructions - no change to the NIC's driver. Attempted to run \SWSetup\SP31172A\Sinstall.exe (installation told me the drivers were there). Sinstall.exe wouldn't even open.

    Am I even going in the right direction focusing on the NIC driver? I don't know what to try next - any response would be greatly appreciated.
  2. jobeard

    jobeard TS Ambassador Posts: 13,285   +281

    use the wired approach and make sure
    1) you have a new password other than the default (a general security issue)
    2) set your own SSID and allow it to be broadcast for the moment.
    save and restart the router

    disconnect the rj45 and enable your wireless adaptor.
    you should 'see the SSID name' as a possible connection point.
    if you have any neighbors with WiFi, you will also see their SSIDs.
    choose yours and it will attempt to connect.

    you may need to play with your firewall settings for
    DHCP Client, BOOTP, DNS
  3. equinox137

    equinox137 Newcomer, in training

    You might also check the MAC address filter on the router itself. It may be denying your wireless NIC an IP address if it is enabled.
  4. toffeapple

    toffeapple Newcomer, in training Posts: 216

    have you tried configuring it with static settings to eliminate IP problems?
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.