TechSpot

WRT54G + XP SP3 - Port Opening

By bman2005
Dec 13, 2008
Topic Status:
Not open for further replies.
  1. Afternoon all-


    After dealing with some unstable issues using Gamespy I have been inspired to try and get the private LAN game back up and running. I have been trying over the past year to get other gamers to see my machine but to no avail. All we get are time out errors - which has led to a battery of port tests.

    It appears that everything is blocked or filtered. I have checked with my ISP and they do not block any ports. However, no matter what I try - I get the same response

    a) connection refused

    I am beginning to think this is a SP3 (XP) issue as I have tried completely bypassing the router (wrt54G), in safe mode with networking and I get the same messages and game response.


    Here is what I have:


    WRT54G Version 2
    Updated Firmware to version 4.21.1

    Windows XP with SP3

    Game trying to plan - Flight Simulator X
    Ports anticipated by FSX = 2300-2400, 6073 and 23456

    I have two workstation running into the router. One system (non-gaming) is hardwired. The second system (FSX machine) uses a wireless adapter D-Link DWL-510

    I don't have any network connection issues as a whole. Everything has been running stable and access is fine. The wireless adapter is under WEP security.

    What I have tried:

    1) Verified that all antivirus software is off (windows and !avast)
    2) Made gaming computer static IP - 192.168.1.110

    3) On router - set port forwarding to the ranges as noted above for FSX

    4) On router - enabled DMZ for 192.168.1.110

    5) On route - unchecked "Block Anonymous Requests"

    6) Connect directly to modem
    7) Safemode + networking


    That's about all I can think of. No matter what I try, I can not see the ports open. I can ping my IP.

    Lost and confused. Any help is appreciated.

    Benjamin
     
  2. LookinAround

    LookinAround TechSpot Chancellor Posts: 8,372   +167

    just an update for you... i've seen your post and plan to look into your problem so i will get back to you again.. probably later today.
     
  3. bman2005

    bman2005 TS Rookie Topic Starter Posts: 56

    LookinAround-

    Hey thanks for the update. I have an update myself. I think I found my solution last night after about 30 straight hours of hunting, trying and pecking.

    I believe that my solution has come from the RPC Locator service. I found some obscure thread that talked about SP3 turning that service off. I turned it back on and now have connection from other users.

    Other information however - all ports are shown as stealth on GRC's ShieldsUP and all ports come back as

    Error: I could not see your service on 173.22.183.162 on port (21)
    Reason: Connection timed out

    When I test on http://www.canyouseeme.org/

    Last but not least when I go to anonymous surfing (http://www.auditmypc.com/anonymous-surfing.asp) I test anonymous. When I enable DRZ - it works as suspected and tells me ports are visible but closed.

    Is there any software that will test ports open / closed or stealth rather than getting into a game and trying and seeing if it does in fact work or not?

    Thanks for your help!

    Benjamin
     
  4. LookinAround

    LookinAround TechSpot Chancellor Posts: 8,372   +167

    Zenmap is a Windows graphical interface front-end for, i think, one of the best and versatile port testing tools: Nmap.

    In fact figuring out all the commands and options can at first appear overwhelming but the Zenmap interface makes it much simpler. Especially if you start Zenmap then click Tools->Command wizard to help you build all the basic commands/scans you can start with.

    Website has some good documentation also
     
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.