X700 Pro shot?

By flyboy1
Mar 10, 2009
Topic Status:
Not open for further replies.
  1. Hello,

    I have a Radeon X700 pro AGP which I would like to be using, but am having some trouble.

    I bought this card several years ago brand new and it worked fine, until I updated the drivers for it one day. The system will reboot, and then go to the Blue Screen of Death right before showing the desktop, and then reboot again, and just keep doing the same thing.

    I dropped in my old Radeon 9500 pro and it works like a charm.

    Here's what I've tried to remedy the situation:

    Complete hard-drive reformat and OS reinstall

    Complete removal of the Catalyst drivers via. driver cleaner + re installation of up to date drivers.

    The card works just fine WITHOUT drivers installed.

    Still no luck. Is this video card ready for the dumpster ?

    Here's some system specs:
    WinXPH Service pack 3
    Pentium IV 1.8
    1 GB DDR RAM
    GIgabyte ATX some or other motherboard
  2. Matthew

    Matthew TechSpot Staff Posts: 6,020   +83 Staff Member

    Nope, just sounds like the latest drivers are having compatibility issues with your system. Try using Omega Drivers or just reverting back to an older version of ATI's official drivers until the BSOD issue clears up.
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.