TechSpot

XP Performance

By mig2000
Oct 3, 2002
  1. PLEASE HELP!!!!!

    I have a Pentium 4/1600 Mhz with 512 meg memory. I bleieve it is the best performance PC in the market place... ANyway, when I got it , XP was running wonderfull - after installing my regular applications and as I am using it everyday, it is looking like a pentium II with 100Mhz. what the hell is going on? I have read all the articles in this site about the BOOT time performance changes and so on and what is bugging me is that I never had this kind of performance problem in the very beggining..... It looks to me that the more I used the DAM PC, the slower the machine gets. Any suggention would be apprecaited.
     
  2. Vehementi

    Vehementi TechSpot Paladin Posts: 3,199

    What are some of the 'regular apps' you installed?
     
  3. boeingfixer

    boeingfixer TS Rookie Posts: 1,245

    Mig,

    I went to an XP tech show when it was just released. They did a demo with Intel and the P-4, if you don't have the right drivers loaded to optamize the P-4 and XP it will run VERY slow. They did a side by side demo of this and I was shocked. Check on the Intel website and the MS website for optamized drivers for both.
     
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.