TechSpot

Youtube videos not loading

By nosebleedXD
Aug 31, 2008
  1. it just happened yesterday, i have no idea what happened but youtube videos are not working

    everything else is fine, i can watch videos on break.com and any other video sites

    i dunno what i did but no youtube videos load at all

    i checked my internet speed and it was at its usual speed

    i tried to watched videos on ie too but it does not work please help >_<

    [​IMG]
     
  2. Rage_3K_Moiz

    Rage_3K_Moiz Sith Lord Posts: 7,286   +24

    Try refreshing a couple of times. It will load after one or two refreshes. Some will not load at all however. This is an ISP problem (for me at least), and the only solution I've found is to use anti-censorship software like FreeGate.
     
  3. nosebleedXD

    nosebleedXD TS Rookie Topic Starter Posts: 256

    hmm wait so whats the freegate and where could i get it
     
  4. Rage_3K_Moiz

    Rage_3K_Moiz Sith Lord Posts: 7,286   +24

    It's an anti-censorship program that allows you to bypass your ISP's proxy. It's available free on Download.com and is easy to run and use.
     
  5. nosebleedXD

    nosebleedXD TS Rookie Topic Starter Posts: 256

    oh its just a proxy i tried it still doesnt work >_<
     
  6. FrankieSmile

    FrankieSmile TS Rookie

    Ohgod. Hi. I think I might have like, the exact same problem. I wasn't sure at first but I saw you posted this yesterday, and mine started yesterday too. And most of all, You mentionned that other sites like break.com worked, and so I tried a few videos there, and what-a-shock, they work for me too!

    I suggest we compare our problems further to be sure its the same and then maybe we check if we have similar applications or plugins installed that might be the source of the problem?

    Did you notice that when you try loading a youtube video, your CPU usage (check with task manager) skyrockets to 100% for whatever browser you are using? And this usage sticks at 100% until you close all browser windows? I looked around the web but only found similar-yet-not-quite-the-same problems that all had found their own solutions that didnt work for me (installing the flash 10 beta, turning off java...), so im pretty glad I stumbled on that topic!
     
  7. FrankieSmile

    FrankieSmile TS Rookie

    I tried using a proxy, and it works. But heres the strange thing:
    My laptop is connected through WI-FI on the same router this computer goes through, so it uses the same DNS and ISP.... yet it can access youtube with no problems. Furthermore, I asked others who have the same ISP I do, and none seem to have this problem. I am stumped...
     
  8. FrankieSmile

    FrankieSmile TS Rookie

    New development! My problem (we still cant be sure we have the same) seems to have gone away by itself, I no longer need a proxy to view youtube videos, it just works now.

    Things I have done since then that might or might not have had anything to do with fixing it:
    - Yesterday I ran a virus scan and it found two Trojans, though the problem was still present afterwards.
    - I defragmented my local and system disks overnight

    When I came back on this morning youtube vids worked.
    Honestly I don't see how the defrag could have helped but it seems to be like, the last thing that happened before I realize youtube worked for me. Maybe it was just a coincidence. I didn't even reboot my computer or anything since yesterday in fact.
     
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.