5.1 speakers and Logitech x-530

By booboo7
Jan 9, 2006
  1. 5.1 speakers and Logitech x-530 PLEASE HELP!


    i have a set of surround sound logitech x-530 speakers and as i had a intergrated sound card i bought a sound blaster live 24-bit 7.1 channel sound card.

    my problem is that only my two front speakers work! For example it is just doing what it used to do when i had my old intergrated sound card.

    as my sound card didnt come with drivers i downloaded them off the creative website seeing as that was my only choice but still i had no succese. I have the option under control panel > adio devices set to 5.1 but still i have no succes.

    if sumone could help me out that would be the best thin in the world as my parents are pretty pissed of that they are not working =[
  2. booboo7

    booboo7 TS Rookie Topic Starter Posts: 20

    any help from anyone?
  3. hewybo

    hewybo TS Maniac Posts: 435

    try this

    I know you've been to creative's site, but I suggest you try it again. They have a system scan of sorts (you may have to approve Directx* install for the scan).
    This is a common problem with SoundBlasters, in my experience, but the scan will recommend the downloads you need. Even after that, I have found that three or so re-boots later, you may have to re-download and install them.

    Creative is very picky with their downloads, so- when installing, be sure to re-start after each driver. DO NOT skip the re-start til all are installed. They will not function properly, so re-boot each time you get the option.

    Also-(I'm assuming Windows XP), be sure that the proper functions are checked in the "sounds and audio devices" of the control panel. >>sounds and audio devices>audio>advanced>5.1 surround sound speakers.

    These steps should do it. Post back either way, and let me know we'll find it- and please your parents! :D
    * should say ActiveX
  4. booboo7

    booboo7 TS Rookie Topic Starter Posts: 20


    thank you for an answer lol! i have been on the creative website but i cnt seem to find a scanner. if you could link this to me thnx =]

    i have downloaded the drivers before by using the normal process of just picking the card and then it finds a driver for u but when i download them it seems to bring 1 only. from what i gather there should be more than 1 thing 2 install ?
  5. hewybo

    hewybo TS Maniac Posts: 435

  6. seanp789

    seanp789 TS Enthusiast Posts: 111

    Are you using digital out? digital out will only produce 2.0 sound except from DVDs.
    If not, do you have 3 analogs connected?

    Are you using 5.1 material? By default music will only play in 2 channels although it can be set to use more my most sound cards. You old sound card may have been set to expand 2 channel audio to all of your speakers.

    **** this guy had the same problem you did and was able to fix using the CMSS console to expand sound to all channels. It goes into more detail from wha i jsut described.
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...