TechSpot

Acer Aspire 5520 DVD-RW disappeared

By WTFFTW
Aug 22, 2009
  1. Everything worked fine until yesterday when I tryed to backup everything from my laptop to dvds because of a scheduled format. Since then the optical drive is not recognized in BIOS nor explorer. The doors open and when I insert a dvd or cd it seems as it is trying to read thru the data. The device is not shown in device manager either. Any ideas?
     
  2. Tmagic650

    Tmagic650 TS Ambassador Posts: 21,067   +169

    Remove the optical drive in the device manager and restart the laptop and see if the drive is reinstalled... If this doesn't work, the drive may be worn out
     
  3. WTFFTW

    WTFFTW TS Rookie Topic Starter

    It's not displayed there anymore nor in BIOS. But, I worked somewhat on the laptop today even disassembled it and now the drive is recognized. Will attempt to install windows all over again, it's giving me bsod for now.
     
  4. WTFFTW

    WTFFTW TS Rookie Topic Starter

    Solved. Lock please.
     
  5. Tmagic650

    Tmagic650 TS Ambassador Posts: 21,067   +169

    No need to lock... This will fade into techspot history on its own. What did you do to solve this?
     
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.