AMD 6950 + Sony Vegas = :(

By lukebussey
Jan 21, 2013
Post New Reply
  1. Hi all,
    I have a Sapphire 6950 2GB Dual Fan Edition (reference BIOS though, stock clocks, all standard - so the standard AMD drivers are used).

    I'm on the latest drivers (Catalyst 12.10, OpenGL 6.14.10.11931, etc), and everything except Sony Vegas works fine with my card.

    I don't want to switch to something like Premiere because I like Vegas, but I really do need GPU acceleration, and can't figure out why this isn't working (because many people buy the 6950/6970 as video editing cards)...

    So does anybody have any idea as to what might be the problem?

    FYI - When in Vegas, there is no option to turn on GPU acceleration, it's blanked out.

    Thanks,
    Luke
  2. Blkfx1

    Blkfx1 TechSpot Addict Posts: 884   +171

    Firstly, upgrade to the latest drivers for the HD 6950.


    After going through a clean install of drivers. Try again to use the GPU acceleration. If it still doesn't work, reply back.
  3. lukebussey

    lukebussey Newcomer, in training Topic Starter

    Okay, will do. Am I not on the latest drivers already then?

    EDIT - I'm doing it now btw, will report back as soon as new drivers are installed.

    EDIT 2 - Still waiting for the uninstall tool to finish, it's taking a while but seems to be working (display restarting a few times)
  4. Blkfx1

    Blkfx1 TechSpot Addict Posts: 884   +171

    Nope, the newest drivers were released on 1/18/2013.
  5. lukebussey

    lukebussey Newcomer, in training Topic Starter

    Oh, brilliant, so that's probably the problem then :) I've uninstalled all my drivers, restarted, and run through the latest AMD Catalyst installer. I did a custom install and installed everything except the SDK (the top option) as that seems unnecessary. Is is necessary?

    Gonna restart now to finish off the install, then I'll try Vegas.

    Thanks :)
  6. lukebussey

    lukebussey Newcomer, in training Topic Starter

    Okay, I successfully updated the AMD drivers, and I'm now definitely on the latest version - but Vegas still won't detect my GPU... so I'm guessing it's a problem with Vegas?
  7. Blkfx1

    Blkfx1 TechSpot Addict Posts: 884   +171

    It will be in your best interest to have all the drivers included in the package. So, you may want to re-install with the SDK included. However, I've never done a custom install when it comes to my GPU drivers. So, I can't say if the SDK is absolutely necessary.
  8. Blkfx1

    Blkfx1 TechSpot Addict Posts: 884   +171

    In the event, once fully installing the new drivers(with SDK included) and you're still not getting GPU acceleration. I would try to create a application profile for Vegas within your Catalyst Control Center.
  9. lukebussey

    lukebussey Newcomer, in training Topic Starter

    I'll try that, thanks very much for your help :)
  10. Blkfx1

    Blkfx1 TechSpot Addict Posts: 884   +171

    No problem. Keep me updated on the situation.
  11. lukebussey

    lukebussey Newcomer, in training Topic Starter

    I'm still having the problem, no detection :(

    I'm not encoding in any weird format, just bog standard MP4 (YUV, Main concept AVC/AAC) which requires openCL.

    My GPU does support OpenCL, as do the drivers... is it something to do with Vegas not finding the available hardware?
     
  12. Blkfx1

    Blkfx1 TechSpot Addict Posts: 884   +171

    Have you tried creating a application profile for Vegas under Catalyst Control Center ?
  13. HalfEatenDonut

    HalfEatenDonut Newcomer, in training

    Luke, a new update for Vegas was release on 1/29/2013 (Vegas Pro 12). Did you install that? I think that fixed this problem for some people. I'm curious if it helped you.
  14. lukebussey

    lukebussey Newcomer, in training Topic Starter

    Sorry I was away for a bit - exams and stuff. I'd kind of given up on this, despite me needing it so much :p

    I've tried creating a profile, but it doesn't do anything (there are no settings under it relevant to OpenGL or CL)


    I haven't tried that, I'm downloading the update now! I was on build 394 throughout this - I'm updating to build 486, which has a huge bugfix list, so hopefully that will help!


    I'm still thinking it's something to do with the AMD drivers being a bit special (no surprise)...

    Thanks for the help guys, especially Blkfx1 :)

    EDIT - I updated to build 486, still a no-go I'm afraid :(
  15. JC713

    JC713 TechSpot Evangelist Posts: 6,793   +882

  16. nottsel

    nottsel Newcomer, in training

    I been having the exact same issue. according to other people downgrade to " 12.3" according to sony that version is compatible
  17. nottsel

    nottsel Newcomer, in training

    If not downgrade again to "11.9."
  18. JC713

    JC713 TechSpot Evangelist Posts: 6,793   +882

    Maybe you should try 13.4 luke, it has updated OpenGL extensions.
  19. nottsel

    nottsel Newcomer, in training

    I have resolved the issue simply uninstall cataylst and use the updated driver only go into device manager manually find driver update from the computer it should be located in C/amd/version/package/driver


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.