Annoying Firefox Problem!

By porkchop_pryde
Mar 20, 2007
  1. I have been using firefox for over a year now and I love it I never had any problems with it until recently. I am going to try my best to describe whats going on.

    Alright basically what is happening is when I try writing in forums using firefox I can't click on the little icons to make my stuff Bold, Underlined, Add the thingy ect though when I use IE or Opera I got no problems with this.

    I noticed this might have came when I installed an extension so I uninstalled all my add ons and still didnt work, I then got desperate and completely uninstalled Firefox but then when I reinstall it all my settings are still the same it was like I never even uninstalled it.

    I then looked up how to completely uninstall it and tried but that still didnt work its like it just doesnt get rid of all the traces on my computer i got rid of the registries, the folders, even the hidden one in the documents and settings folder and still when i reinstall it, it just shows up as it did before I uninstall it.

    Is there anyway I can fix this problem its really annoying me even on this forum I cant use any of the lil features above to use like emoticons ect unless I manually type the code!
  2. kitty500cat

    kitty500cat TS Evangelist Posts: 2,154   +6

    Hi, welcome to TechSpot! :wave:

    What version of Firefox are you running? I think that on some older browsers some of the buttons don't work. I recommend updating to the latest version (version 2.something, I think).

    Regards :)
  3. porkchop_pryde

    porkchop_pryde TS Rookie Topic Starter

    Thanks and this forum is cool :)

    Yes I have the latest I believe its like version 2.02 or something like that its the one I have.
  4. thewoosterisroot

    thewoosterisroot TS Enthusiast Posts: 192

    Alright, I'm next to positive this has something to do with your problem ;)
    Now, those little buttons (if my understanding is correct) are based on javascript, so the first thing you should do is:

    I. Firefox>Tools>options>Content
    II. Maker sure "Enable Javascript" and "enable Java" are both clicked.

    Also, do you have the latest flash player?

    *note* One of firefox's extensions some people seem to like, "noscript", will block java and javascript, so if you decide to use it you will need to "allow" or wherever for java to work.
  5. porkchop_pryde

    porkchop_pryde TS Rookie Topic Starter

    thanks for the help man but that is still not the problem because those are both checked and i downloaded the latest flashplayer as well :(

    Also I dont have the add on which you described on firefox so that wouldn't be the issue either.
  6. Po`Girl

    Po`Girl TS Rookie Posts: 595

    Try starting Firefox in Safe Mode (that`s Firefox`s safe mode not Windows safe mode) -

    (Start/Programs/Firefox(safe mode) - click Continue in Safe Mode
    that will set Firefox to the state it was when you first installed it.

    You can get out of safe mode,by just closing FF and reopening it.

    If the problem goes away in safe mode,then it`s caused by one of the options

    you see when safe mode starts.

    If you want to try fully uninstalling FF again here`s my method -

    1.Uninstall FireFox from Add/Remove Programs - reboot -

    2.Remove the C:\Program Files\Mozilla Firefox folder from Windows Explorer -

    3.Remove C:\Documents and Settings\*your user profile*\Application Data\Mozilla -

    4.Run RegClean and remove the Mozilla entries that pertain to FireFox.

    You'll see the entries in the default view of RegCleaner, which should be open to the software tab -

    5.Reboot - reinstall FireFox.
  7. thewoosterisroot

    thewoosterisroot TS Enthusiast Posts: 192

  8. porkchop_pryde

    porkchop_pryde TS Rookie Topic Starter

    Hey thanks this method worked great and now everything is working but I think I saved the wrong file from my bookmarks because I put the bookmarks.html file back into the folder and its not doing anythign :s
  9. thewoosterisroot

    thewoosterisroot TS Enthusiast Posts: 192

    Glad you got that working. Ok, bookmarks, you may want to read the first few paragraphs here:

    Which pretty much means you need to put the bookmarks in a folder that is pretty much hidden, so either follows those instructions OR this should work:

    I. Open "my computer"

    II. Tools>folder options> view> show hidden files

    III. C:> Documents and settings>your use name>application data>Mozilla> firefox>profiles> whatever the heck "default"

    IV. That should be where you put your bookmarks. :)

    Or this may even work:

    BTW, I highly suggest using this to backup your bookmarks:
  10. Po`Girl

    Po`Girl TS Rookie Posts: 595

    There`s another good page HERE if you need any more pages :)

    Firefox keeps copies of bookmarks all over the place.
  11. Tedster

    Tedster Techspot old timer..... Posts: 6,000   +15

    upgrade to the latest version. See if that works.
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...