TechSpot steals browser home page

By humblejohn
Jan 27, 2009
  1. wasn't sure where to put this post but has somehow managed to insert itself as my home page. I tried internet options in control panel. typed in with no luck. continues to boot up as if I had done nothing. I erased from the "search results" section and still nothing changes. I set google as the default home page-nothing works. Is there anyway to get home page changed to google. thanks in advance
    Browser is Mozilla
    dell 4600c w/19 lcd ; 2.4 p4, 80 g hd
    nvidia geforce 4 mx 440 w agp8x
  2. mailpup

    mailpup TS Special Forces Posts: 6,964   +355

    Internet options would change only Windows Internet Explorer browser. Do you have Firefox and if so which version? It's not clear to me but did you try changing the home page under Tools > Options > Main?
  3. Bobbye

    Bobbye Helper on the Fringe Posts: 16,335   +36

    Once is on the system, it gives you a Toolbar, a search feture and a few other entries. Have you tried taking all related entries off of Startup, then uninstalling it?

    Easiest to boot into Safe Mode:
    Start> Run> msconfig> enter> Selective Startup> Startup tab> UNCHECK all entries> Apply> OK.

    Control Panel> Add/Remove Programs> UNINSTALL all entries.

    Reboot into Normal Mode: NOTE: you will get a nag message that you can ignore and close after checking 'don't show this message again.' Stay in Selective Startup.

    Now reset the homepage to whatever you want. If you still cannot, follow this:

    Internet Explorer 6 (presumably 7 too)
    And a note for the future: look carefully at any screen where you are doing a download. Many are coming with these nuisance Toolbars and programs already checked. It's easier to uncheck there than to get rid of it once on the system.
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...