Assassin's Creed on the i7

By kofshinobi
Sep 5, 2010
Post New Reply
  1. Hey I'm new here so I think this post is in the right spot. I just got a new dell studio 15 and I am installing my old games on it. I installed Assassin's creed on it and when I finished I got a notice saying that my cpu isn't good enough to run it it needs to run 1.9Ghz and mine runs 1.73. It seems to me that being a quad core and being able to overclock to 2 GHz there shouldn't be a problem. Any ideas?


    Operating System: Windows 7 Professional 64-bit (6.1, Build 7600) (7600.win7_gdr.100618-1621)
    Language: English (Regional Setting: English)
    System Manufacturer: Dell Inc.
    System Model: Studio 1558
    BIOS: Ver 1.00 BIOS A07 PARTTBLr
    Processor: Intel(R) Core(TM) i7 CPU Q 740 @ 1.73GHz (8 CPUs), ~1.7GHz
    Memory: 8192MB RAM
    Available OS Memory: 8124MB RAM
    Page File: 2481MB used, 13765MB available
    Windows Dir: C:\Windows
    DirectX Version: DirectX 11
    DX Setup Parameters: Not found
    User DPI Setting: 96 DPI (100 percent)
    System DPI Setting: 120 DPI (125 percent)
    DWM DPI Scaling: Disabled
    DxDiag Version: 6.01.7600.16385 32bit Unicode
    Video Card: ATI Mobility Radeon HD 5400 Series
  2. raybay

    raybay TS Evangelist Posts: 7,241   +9

    Assassins have a creed?

    It should run anyway. Did it refuse?
  3. LinkedKube

    LinkedKube TechSpot Project Baby Posts: 3,481   +44

    Make sure your power settings aren't on balanced or power saver which reduces the multiplier on the cpu and gives you slower speeds.
  4. you use a 286

    you use a 286 TS Rookie Posts: 63

    Is it just able to overclock at 2.0 ghz, or do you actually have it overclocked at that speed. If it is at that speed it should run, if not it will still ask you for the 1.9 ghz.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...