ASUS K8S-MX mobo problems

By apple1ma
Sep 10, 2007
  1. I've had this mobo for about 2 or so years, last night i was upgrading the ram i had in my system. After trying to start my computer up with the new sticks of ram, the power light came on and everything sounded like it was running but nothing was loading. My monitar was idle, but the light on my CD drive was on. The new ram i got had lights that were on it so i know the ram was on because the lights were on. My computer now would not turn of by hitting the power button or holding it down so i had to manually unplug it from the back. After doing so i switched back in my old ram and now i'm getting the same problem.

    The LED on my motherboard is lighting up, and when i go to turn on my computer on nothing seems to happen after the lights and fans start running.

    I've tried clearing the RTC RAM and i tried the USB device wake up.
  2. AlbertLionheart

    AlbertLionheart TechSpot Chancellor Posts: 2,026

    Please try and clean the RAM slots on the motherboard with a compressed air blast (you can get it in a can). Then try one stick at a time, and in each slot at a time. You might find that one of the slots has failed.
  3. Tedster

    Tedster Techspot old timer..... Posts: 6,000   +15

    read the upgrading ram guide in the guides forum. Read the part about asus.
  4. apple1ma

    apple1ma TS Rookie Topic Starter

    I just used a dustgun on the ram slots and tried each stick in slot one at a time and neither seem to be working. I think its time for a new computer, any other suggestions?

    thanks for the replies so far :D
  5. apple1ma

    apple1ma TS Rookie Topic Starter

    thanks alot, i'll try that when i come home tomorrow
  6. apple1ma

    apple1ma TS Rookie Topic Starter

    okay, i unplugged everything except the wire that connects the power button to the motherboard, and the PSU and heatsink. I only got 1 beep when i started up the computer, which is the normal sound it makes when i used to start it up. I tried each stick of ram one at a time, and then both together and im getting the same normal sound.. Now when i plug my video card in and my monitar into that, im not getting any error beeps, but im not getting a Post screen either. Im not sure why this is, i tried plugging in my monitar into the onboard video and im still getting nothing... I also tried using another monitar and still nothing.
  7. apple1ma

    apple1ma TS Rookie Topic Starter

    actually now when i try to plug in my hard drive or CD drives im not getting any beeps at all... And the light on my front panel that usually indicates computer activity is solid as long as my PSU is on.
  8. AlbertLionheart

    AlbertLionheart TechSpot Chancellor Posts: 2,026

    One beep is good. If you plug something in and the beeps stop, then whatever you plugged in is a source of a problem. Take off the video card and connect the monitor to the onboard port (it will not be active if a video card is in a slot). You should get a clean boot. Power off and connect your hard drive. Check in the BIOS to see if it is seen by the system.
    If this does not work, try another drive if you have one or perhaps a CD drive to see if the system detects it.
    If no drives are seen, make sure all the settings are set to autodetect the drives and check the signal ribbons and power connections to make sure they are OK. You can feel/hear a drive spinning up.
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...