TechSpot

BSOD error in win7

By maazcheema
Feb 26, 2011
Post New Reply
  1. I am recieving a BSOD error in win7 32bit. the error occurs randomly it states

    "IRQ less or not Equal"

    i do=nt know waht is causing it.

    my breif system info is

    Dell optiplex 755
    Core 2duo processor e7400
    2 gb ram
    300 watt psu
    nvidai 9800 gt gpu

    The attcahment is the dump file.please review it and help me urgenly..

    thanks allot
     

    Attached Files:

  2. Route44

    Route44 TechSpot Ambassador Posts: 11,966   +70

    We need more information:

    1. What are you doing when these errors occur?

    2. Have you done any updating recently or installed any new software?

    3. Please attach you five most recent minidump files - not including the one you have already given - in one Zip file. Please don't zip them individually.
     
  3. maazcheema

    maazcheema TS Rookie Topic Starter Posts: 21

    help plz

    recently i have installed Avast antivirus. part from that nothing much..i have only 1 dump file saved which i have attached.
    if th error comes again i will make more attachments but untill then plz make do withe the one available and guide me

    thank u..
     
  4. Route44

    Route44 TechSpot Ambassador Posts: 11,966   +70

    Okay, first Avast is an excellent software. I run the $ version on my wife's new laptop that runs Windows 7 64 and never a problem. I run the free version on my son's PC and two laptops without issues as well.

    However, in your one minidump the Avast driver aswMonFlt.sys was not able to load and it was caused by the Windows OS driver ataport.sys. These are somehow conflicting.

    Questions: What other security software are you running in real time protection? What security software were you running prior and did you uninstall it?
     
  5. maazcheema

    maazcheema TS Rookie Topic Starter Posts: 21

    from what u are telling me the OS driver ataport.sys is the problem.. plz tell me waht this driver is related to. i have just run a sfc/scannow and it has revealed some errors.

    before that i was using microsoft security essentilas and it was running great till one day i updated it and it was no more there. i dont kn ow waht hapened. every time i tried to install it gave me some error. i tried other softwares like kaspersky but they didnt install either. Avast was the only one which installed correctly.

    Plz tell me that there is NO hardware problemcoz i cant afford it right now.
     
  6. Route44

    Route44 TechSpot Ambassador Posts: 11,966   +70

    At this point I believe it is a driver issue. However, what errors are you speaking of?
     
  7. maazcheema

    maazcheema TS Rookie Topic Starter Posts: 21

    i am trying to upload the log file but its too big..can u suggest someother way to upload load it to u?
     
  8. Route44

    Route44 TechSpot Ambassador Posts: 11,966   +70

    There is a Zip option offered in the Manage Attachments button. Zip will compress your log.

    I am wondering if a Windows Repair is in order.
     
  9. maazcheema

    maazcheema TS Rookie Topic Starter Posts: 21

    i have tried windows zip option.it only says that a file upto 200kb can be uploaded.mine is bigger than that..

    i am thinking of reinstalling my windows and updating my BIOS version to A17..my current version is A11. My system is dell optiplex 755. Also dell gives the drivers for western digital hard drives which i am using so im thinking of installing them. plz advice me if i should reinstall windows and update bios and hard disk drivers. Also plz tel me what is Atapi since im thinking ataport.sys is related to it.
     
  10. Route44

    Route44 TechSpot Ambassador Posts: 11,966   +70

    ataport.sys is a Windows driver dealing with storage. Atapi is for your CD/DVD drives.

    What concerns me is that Windows Essentials disappeared, Kaspersky didn't install and Avast is having issues. Here is what I think might be the issue.

    1. A Windows Repair is needed because the OS became corrupted. But...

    2. If #1 is correct then how did it become corrupted? Perhaps you are infected. It wouldn't be a bad idea to go to our Virus and Malware Removal forum and read and follow the directions given in the Updated 8 Step sticky.

    3. The harddrive itself may have some bad sectors. Dell should provide you with utilities to run harddrive diagnostics. Do so.

    4. BIOS updates certainly could help. They aren't hard to do but make sure a) you do not lose power and b) never do this wirelessly. Make sure you are connected to your router via ethernet cord.
     
  11. maazcheema

    maazcheema TS Rookie Topic Starter Posts: 21

    i updated the MSE which caused it to disappear. maybe the update caused the files to be corrupted.simply formatting and reinstalling the windows might help..

    Also guide me how to run a system repair and to check for bad sectors..

    my motherboard and casing are branded. rest i have bought on my own without any DELL interfearence.
     
  12. Route44

    Route44 TechSpot Ambassador Posts: 11,966   +70

    What OS are you running and what is the make of your harddrive?
     
  13. maazcheema

    maazcheema TS Rookie Topic Starter Posts: 21

    My OS is windows 7 ultimate x86 Version 6.1.7600 Build 7600
    My harddrive is Western Digital WDC WD1600JS-75NCB3 ATA DEVICE 250 GB
    I HAVE OTHER 160 GB ATTACHED ON a SERIAL PORT. IT SHOWS IN WINDOWS BUT THERE IS NO MENTION OF IT ON DEVICE MANAGER. I DONT KNOW WHY. I CAN USE THIS OTHER DEVICE BUT DEVICE MANAAGER DOESNT SHOW IT..it is also of western digtal.
     
  14. Route44

    Route44 TechSpot Ambassador Posts: 11,966   +70

  15. maazcheema

    maazcheema TS Rookie Topic Starter Posts: 21

    Yes it shows in the BIOS
     

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...