TechSpot

Cannot find Realtek in my Device Manager

By cjgeons
Dec 30, 2012
Post New Reply
  1. Hi
    System Info: Asus P5G41T-M LX
    Win7 64bit

    Problem started when a red cross mark appeared on my sound icon.I installed,reinstalled Realtek driver several times.But nothing happened.
    I googled the problem.Some said about enabling onboard radio.But cannot find that option in Bios.
    When I installed Realtek ,I checked C drive for installed files.But Realtek Folder does not contain any files(just 3.7 MB).

    Thank You for your Help.
  2. learninmypc

    learninmypc TS Evangelist Posts: 5,235   +232

    Go into your Control panel & see what it shows in there.
  3. JC713

    JC713 TS Evangelist Posts: 6,956   +902

    If you install the official realtek audio driver does it say nothing was detected?
  4. cjgeons

    cjgeons TS Rookie Topic Starter

    yes.I installed and uninstalled Different versions of Realtek(win 7 64 bit) from different sites including official realtek site and Asus site.

    First of all Thank You for replying.Actually after installing Realtek it is not appeared in control panel-->Hardware and sound.The problem is it is not getting installed.When I check the installed files in program files.it is only around 4 Mb in size.How could that happen?

    I used msinfo32 command in "run" and found the sound device.It displayed as follows

    Name:High definition audio device
    Manufacturer:Microsoft
    Status: OK

    Also in Device manager-->sund and game controllers,it shows "High definition audio device".I tried the update option too and it says its already up to date.
    Still there is no sound.
  5. LookinAround

    LookinAround TechSpot Chancellor Posts: 8,372   +167

    List any Problem devices
    • Make sure devices are connected and powered on
    • Click Start->Run, enter: msinfo32. Click the + sign next to Components to expand it
    • Click Problem Devices. Anything appear?
    • If yes, click on it, Ctrl-A to select all, Ctrl-C to copy it, Ctrl-V to paste into next post
    • On the other hand, if no devices are listed, tell me so
    Generate and attach a DirectX report
    • Click Start->Run, enter dxdiag and click OK
      ===> If you’re running 32 bit Windows, dxdiag will launch on its own
      ===> If you’re running 64 bit Windows, you’ll see 64-bit DxDiag. Click it to launch the 64-bit version of dxdiag
    • Notice progress in lower left window corner
    • When done, click Save Information button and save as a text file to your Desktop
    • Attach it to your next post by clicking the Upload a File button
  6. cjgeons

    cjgeons TS Rookie Topic Starter

    T
    Thank You or replying.I did each step as u asked me to do.There was no problem devices.And I did dxdiag and information is uploaded.

    Attached Files:

  7. LookinAround

    LookinAround TechSpot Chancellor Posts: 8,372   +167

    High Definition Audio connects like this
    Windows <====> Hi Def Audio Controller <==> Hi Def Audio Devices

    Your DxDiag show the controller is detected and working (which also means your onboard audio is already enabled). Problem seems to be with the HD Audio Devices.

    Try this first: Open DevMgr. Look under System Devices and right click the High Def Audio Controller select Uninstall. Now reboot your computer. Windows will reinstall the controller driver and the controller will try to detect all HD audio devices again (just in case all the audio devices weren't detected before)

    If you still have no luck installing Realtek drivers from the ASUS website, See How To Report Your Computer's Device Manager Data

    Be sure to Save As Tabular Text.txt file when saving the report on your computer. Upload the data to your next post
  8. misor

    misor TS Maniac Posts: 1,016   +153

    How to install realtek hd audio driver:
    1. download latest realtek driver from http://www.realtek.com/downloads/do...=24&Level=4&Conn=3&DownTypeID=3&GetDown=false
    or from motherboard manufacturer's website http://www.asus.com/Motherboards/Intel_Socket_775/P5G41TM_LX/#download
    2. uninstall current realtek hd audio driver and reboot.
    3. install latest realtek hd audio driver and reboot.

    at first, please select only the asus source of hd audio codec driver as the generic driver from realtek may not work on some motherboards.
    (my laptop's realtek audio would not be enabled by installing drivers from realtek but would immediately work by installing realtek audio codec driver from intel; yours could be different though)
  9. cjgeons

    cjgeons TS Rookie Topic Starter

    When I looked under System Devices I found two "High Def Audio Controller" (I have attached a screen shot).I uninstalled both of them and restarted the System.But it didn't sort out the problem.
    I have attached Device manager Data too.

    Attached Files:

  10. cjgeons

    cjgeons TS Rookie Topic Starter

    I did that several times.I installed and uninstalled Realtek from different sources(Asus and realtek websites).But nothing happened.
    I don't know what is the problem.
  11. misor

    misor TS Maniac Posts: 1,016   +153

    Try to reinstall original realtek hd audio codec driver from the driver installer cd/dvd that came with your motherboard.

    if you are successful in restoring the realtek driver to a working state and willing to update the driver to a newer version, download a version you like from http://filehippo.com/download_realtek_high_definition_audio_vista_64/
    (version 2.65 to 2.67, then 2.70)
     
  12. cjgeons

    cjgeons TS Rookie Topic Starter

    I installed realtek from mother board DVD too,but didn't worked.And I already tried version 2.70 of Realtek
  13. LookinAround

    LookinAround TechSpot Chancellor Posts: 8,372   +167

    I should have caught that! The System Device section of your dxdiag report also shows two Hi Def Audio Controllers:
    > You have both onboard audio plus an addon graphics card ATI HD Radeo 5450 which also provides HD Audio. They each have their own HD Controller and HD devices that connect to them.

    Let's this time go look for HD audio drivers for your ATI Radeon 5450. Go HERE and click on the Automatic Detect and Install link on the page. Does the HDMI port on the grahics card work now? Run a new dxdiag. Does DxDiag show the Radeon 5450 as a working sound card?
  14. cjgeons

    cjgeons TS Rookie Topic Starter

    I
    I did as u said.I have attached new dxdiag info below.I dont use hdmi port of the graphics card.

    Attached Files:

  15. cjgeons

    cjgeons TS Rookie Topic Starter

    Now ,in dev manager-> sound and game controllers ,it shows AMD High Def Audio Device
  16. LookinAround

    LookinAround TechSpot Chancellor Posts: 8,372   +167

    OK. So that must be the audio device on your graphics card now with its driver installed....

    Next step: I apologize but please give me another Device Manager data report (as you did in post #9 above) BUT this time please Save As Tab Delimited Text. (My error, but I now realize I need the report saved as tab delimited text as otherwise some information I need gets lost)
    DevManView Save.jpg
  17. cjgeons

    cjgeons TS Rookie Topic Starter

    I have attached DevManReport

    Attached Files:

  18. LookinAround

    LookinAround TechSpot Chancellor Posts: 8,372   +167

    I'm just going to focus on your onboard audio..... After reviewing your data, I'll explain
    a) What I see as the problem with your onboard HD audio device
    b) How you can visualize the problem for yourself
    c) What you can try next

    As I see it, the onboard HD audio controller isn't detecting the onboard HD audio device. This can happen if a) the audio device failed or b) the controller, itself, isn't working correctly. Windows won't install Realtek because it doesn't see the device the Realtek driver is supposed to be for.

    I believe you should be able to see this problem yourself, if you tell Device Manager to View Devices by Connection. DevMgr will then show you how your devices connect to each other instead of by category. I provide a Win 7 device manager snapshot of my own computer below. (Coincidentally, my computer uses the same addon ATI Radeon 5450 as you do)

    Open Device Manager. Click View->Devices by Connection. To see how devices connect to the computer PCI bus, expand ACPI->Microsoft ACPI->PCI bus. You should now be able to distinguish between the two audio controllers.
    => The onboard controller connects directly to the PCI bus
    => The contoller on the ATI card connects through PCI Express chipset

    Note that each audio controller should have at least one audio device connected to it. My guess is on your computer you won't see ANY audio devices connected to your onboard audio controller. (see my example from my computer below)
    HD Audio Controllers.jpg

    If the onboard controller can't detect the onboard audio device, Realtek will never install for that device.

    Things to try:
    1) Look through all BIOS setup menu pages again. (Be sure to look through all setup menu pages) Look for an option name such as onboard audio or integrated audio. Disable it and boot up. The onboard controller should disappear from DevMgr. Then reboot with onboard audio enabled. The onboard controller will reappear. See if an audio device is now detected.

    2) After step 1) if still a problem, try uninstalling the onboard audio controller driver again. Tip: Instead of rebooting at this point you can also click Action->Scan for Hardware changes. Windows should reinstall the driver and the controller try and detect the audio device again.
  19. cjgeons

    cjgeons TS Rookie Topic Starter

    I checked as you said.You are right ,there was no audio device connected to my onboard audio controller.In BIOS I didn't find any option to enable/disable Onboard audio.I was searching for it for about 2 weeks.I have checked every option in BIOS.But couldn't find onboard audio setting.
  20. cjgeons

    cjgeons TS Rookie Topic Starter

    I think the problem is that Win 7 is not detecting onboard sound device.I m using Win 7 Ultimate.
  21. cjgeons

    cjgeons TS Rookie Topic Starter

    also in dxdiag its showing "No sound card was found. If one is expected, you should install a sound driver provided by the hardware manufacturer".
  22. LookinAround

    LookinAround TechSpot Chancellor Posts: 8,372   +167

    1. First, an editorial note: You don't need to click Reply (which inserts a quote of all of the prior post) unless there's something specific in it you want to include. (Not inserting a quote "everything" makes the thread easier to read for others) For cases where you might be responding to several people, simpy use the @ sign followed by their user name does the trick. Example for case LookinAround
    "@LookinAround" would appear as below (I added the " " so you can see it's affect. Normally don't use the double quotes to get things such as the two references below)

    LookinAround
    blah blah blah

    learninmypc
    blah blah blah

    2. I downloaded the P5G41T-M LX User's Manual (English). See BIOS section 2.4.3 about Chipset settings
    > Go to BIOS Advanced tab​
    > Click Chipset. Under Southbridge Configuation, appears there should be Audio Controller option you can enable/disable​

    See if that lets you toggle onboard audio enable/disable. Also it may not help, but won't hurt, to try install the chipset drivers again.
  23. cjgeons

    cjgeons TS Rookie Topic Starter

    Sorry for the inconvenience.I found the option to Enable audio controller,it was already enabled.I disabled and booted,then enabled again( just hit and trial),it didnt worked too.
  24. misor

    misor TS Maniac Posts: 1,016   +153

  25. cjgeons

    cjgeons TS Rookie Topic Starter

    misor
    I did that, but it didn't worked.I also checked Windows audio services,they are running too.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.