TechSpot

Computer becoming extremely slow. It's brand new.

By PatrickRT
Jan 18, 2014
Post New Reply
  1. I just got this computer about 2 weeks ago, and ALREADY I am getting lag problems. I have the CPU widget, and when I am JUST on the web browser, I get about 50-70 CPU being used. My specs are:
    AMD Athlon(tm) 64 X2 Dual Core Processor 4400+
    Nvidia GeForce GT 430
    And if it helps, I AM using an external HDD for most of my programs, since the original PC came with only 250 GB.
     
  2. cliffordcooley

    cliffordcooley TS Guardian Fighter Posts: 8,202   +2,637

    Which applications do you have installed to the external?
    What connection type and speed is the external HDD?

    I'm not sure I would install applications to a USB 2.0 drive. Especially if the applications are used frequently. I know I wouldn't if the application installs memory resident system monitors that run 24/7. However I usually disable these monitors from running at startup as well.
     
  3. PatrickRT

    PatrickRT TS Rookie Topic Starter

    The external drive only has 2 GAMES on it. I have only 2 programs I am aware of on startup also, Spotify, Skype. Donno what connection type and speed is.
     
  4. cliffordcooley

    cliffordcooley TS Guardian Fighter Posts: 8,202   +2,637

    USB(2.0 vs 3.0), eSATA(2.0 vs 3.0), Firewire(S400 <> S3200), Ethernet(10/100 vs 1000), Thunderbolt, ect...?

    I'm probably asking the wrong questions anyway. Have you also scanned for Mal-ware?
     

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...