TechSpot

Computer becoming extremely slow. It's brand new.

By PatrickRT
Jan 18, 2014
Post New Reply
  1. I just got this computer about 2 weeks ago, and ALREADY I am getting lag problems. I have the CPU widget, and when I am JUST on the web browser, I get about 50-70 CPU being used. My specs are:
    AMD Athlon(tm) 64 X2 Dual Core Processor 4400+
    Nvidia GeForce GT 430
    And if it helps, I AM using an external HDD for most of my programs, since the original PC came with only 250 GB.
  2. cliffordcooley

    cliffordcooley TechSpot Paladin Posts: 5,828   +1,439

    Which applications do you have installed to the external?
    What connection type and speed is the external HDD?

    I'm not sure I would install applications to a USB 2.0 drive. Especially if the applications are used frequently. I know I wouldn't if the application installs memory resident system monitors that run 24/7. However I usually disable these monitors from running at startup as well.
  3. PatrickRT

    PatrickRT Newcomer, in training Topic Starter Posts: 18

    The external drive only has 2 GAMES on it. I have only 2 programs I am aware of on startup also, Spotify, Skype. Donno what connection type and speed is.
  4. cliffordcooley

    cliffordcooley TechSpot Paladin Posts: 5,828   +1,439

    USB(2.0 vs 3.0), eSATA(2.0 vs 3.0), Firewire(S400 <> S3200), Ethernet(10/100 vs 1000), Thunderbolt, ect...?

    I'm probably asking the wrong questions anyway. Have you also scanned for Mal-ware?


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.