TechSpot

'Connect to Printer' errors on login after deleting network printers

By rkudyba
Jan 31, 2011
Post New Reply
  1. We've recently removed 2 printers from our network (a Konica and a HP). Whenever any user EXCEPT 'Administrator' logs in now, they get the below "Connect to Printer" error dialog box. I've made sure to remove the printer from Printers and Faxes, and even the drivers in 'Server Properties' (under the File menu in Printers and Faxes). They're all Windows XP SP3 and rebooted after removal of the drivers.

    I even tried Bruce Sanderson's cleanup suggestion. To no avail.

    Here's how the error dialog box looks:

    ---------------------------
    Connect to Printer
    ---------------------------
    Windows cannot connect to the printer. Either the printer name was typed incorrectly, or the specified printer has lost its connection to the server. For more information, click Help.
    ---------------------------
    OK Help
    ---------------------------

    I took a look at the suggested registry fix at this techspot discussion but I don't think it applies to our problem.

    Anything else to try?
  2. jobeard

    jobeard TS Ambassador Posts: 13,400   +313

    I think every client with prior access to these printers will need to Delete Printer and as a Domain Admin, you will need to create the delete.script
  3. rkudyba

    rkudyba TS Rookie Topic Starter Posts: 46

    I've deleted the printer whilst logged in as Administrator, assuming you mean from Start --> Printers & Faxes. That doesn't work.
  4. jobeard

    jobeard TS Ambassador Posts: 13,400   +313

    exhamine this

    While it addresses spooler issues, perhaps some residule controls are left in the client spooler area for those old printers and removing them will stop this symptom
  5. rkudyba

    rkudyba TS Rookie Topic Starter Posts: 46

    No luck @jobeard, tried removing them all, rebooted, still same dialog box.
  6. jobeard

    jobeard TS Ambassador Posts: 13,400   +313

    sorry - I'm out of ideas - - -
  7. LookinAround

    LookinAround TechSpot Chancellor Posts: 8,369   +167

    Not sure if this might apply but i think worth a check.

    Open Device mgr, you need to click View->Show Hidden Devices to see Printers category. Do they appear??

    If not, close DevMgr. Then see HERE to also be able to view "non-present" devices (i'm not sure how "non-present" applies specifically for the case of printers, but i think also good to check)

    When you're done, you might want to remove the environment variable as typical users don't have the "non-present" option set

    /* EDIT */
    Have you also double checked the local computers for anything relevant that might still appear in Add/Remove Programs?
  8. rkudyba

    rkudyba TS Rookie Topic Starter Posts: 46

    No dice. See attached screen shot, no printers showing in Device Manager nor Add/Remove Programs. And we removed an hp Laserjet 4200 as well as a Konica copier and both are throwing the alert box.

    Attached Files:

  9. LookinAround

    LookinAround TechSpot Chancellor Posts: 8,369   +167

    OK. Nothing about your printers as devices. A couple more things you might try
    1) Open a command prompt window. Enter net use Any interesting/suspect network connection data appear?

    2. I'd guess the error can also be found in Windows Event Log. Check the system log. There may be more specific data left in the Event Log that may help
  10. rkudyba

    rkudyba TS Rookie Topic Starter Posts: 46

    Son of a gun! After all this time I believe I found the problem. We had a login script, located in \\ourdomain\sysvol\OURDOMAIN\Policies\{RANDOM-STRING}\User\Scripts\Logon, and it was NOT referenced in Active Directory nor Group Policy Edit. I ran a utility called Autoruns, found a path in a tab that showed all the startup items, edited the script by removing 2 entries to the old printers and voila.

    These must've been put in a while back before my time because I didn't even know there were any logon scripts! Side question: any idea why there are a few directories in the 'Policies' sub-directory?
  11. LookinAround

    LookinAround TechSpot Chancellor Posts: 8,369   +167

    Good job! (and good thinking. Autoruns is a great tool)

    re: policies directory. Someone else might have that answer. i don't know how Policies are organized in the registry
     
  12. jobeard

    jobeard TS Ambassador Posts: 13,400   +313

    the policies are on the D.C. side, I beleive - - I've not gotten to work very much with that stuff - - just conceptually.
  13. rkudyba

    rkudyba TS Rookie Topic Starter Posts: 46

    Yes it's just odd that it's not reference in the Users within AD/Properties.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.