TechSpot

Counter Strike Source Lag - tried everything

By jclarke91
Jul 11, 2009
  1. Hi. Just wondering if anyone can help with my lag issue in CSS.

    I have a Dell XPS 3.2 Ghz, 2 GB RAM, x800 xt. I'm connected to a router, and have download speeds of 4.8 and upload speeds of 0.4. My ping in game is around 40.
    I have tried various different rates, update and cmd rates but to no avail. I have also used custom cfg files to improve my framerate, which is around 70-80. I have rang up my ISP who say the line is fine, and they have increased speeds and lowered latency for me.

    I have tried to download the latest driver for my graphics card. I say tried but the version still says 6.14 on my dxdiag. However, hardware aside I have always played this game and have had no issues until late. I have performed virus and spyware checks, and am sure nobody is stealing my bandwith.

    I will post any information needed. Thanks for your help in advance.
     
  2. jclarke91

    jclarke91 TS Rookie Topic Starter

    Further info that might help anyone.. I have created a server with a few bots, and the lag is still happening. I don't really know what this means but I'm sure it would help if anybody was trying to think of the problem. Thanks.
     
  3. snowchick7669

    snowchick7669 TS Maniac Posts: 660

    Hi there,

    You could try running this program which is designed to improve game performance by killing any unneeded backround processes. It may be that you have a lot going on in your machine and that's causing the lag.

    It has a 'Game mode' and then a 'Normal mode'. It actually increased my fps from 160 to 180 in CSS
     
  4. jclarke91

    jclarke91 TS Rookie Topic Starter

    Thanks for your reply. I have tried this but it doesn't help unfortunately. It has been suggested that maybe this is an issue with my graphics card. :\ Thanks.
     
  5. LinkedKube

    LinkedKube TechSpot Project Baby Posts: 3,481   +44

    it is your graphics card. you're getting 70+ fps? and its an issue?
     
  6. jclarke91

    jclarke91 TS Rookie Topic Starter

    Yeah im getting over 70 fps all the time, but it still lags. The players movements aren't smooth, and their running is jerky.

    I have had this graphics card for years and have always been able to play CSS fine with it, so it is strange why it is only a problem now. Thanks
     
  7. jclarke91

    jclarke91 TS Rookie Topic Starter

    I have used Fraps to capture a video of the lag, and uploaded it for youtube if anybody wants to see the problem I'm having.

    As you can see in the video, the lag is on the weapon movements, as well as the players running in front of me, they are very jerky.

    One of the video is played online, and another is offline against bots, still with the same lag. Thanks.

    http://www.youtube.com/watch?v=_pMlVkNk6uc
    http://www.youtube.com/watch?v=XvxWr91efec
     
  8. syde

    syde TS Rookie Posts: 113

    It's a sign that it's time to let go of that old game and play a new FPS :)

    good luck
     
  9. jclarke91

    jclarke91 TS Rookie Topic Starter

    Right well I've just spend 15 quid on it and I can't play it, so I think ill try and sort the problem first.
     
  10. jclarke91

    jclarke91 TS Rookie Topic Starter

    I have made my own dedicated server, and then played on it through a LAN. When I done this, there was no lag at all in the game, and everything ran fine and smooth. Could this narrow the problem down? Thanks.
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...