Dead BIOSTAR motherboard?

By kane702
Jan 1, 2007
  1. I have a BIOSTAR TForce SLI mobo and it has caused me problems from day one. Well now I think it's finally dead. It takes forever to get past the POST screen and many times just frezes there. If by chance I can get it past that screen it trys to detect a RAID and wont go any further. I dont have a RAID and hav turned the option off in the BIOS. The HDs are set up as IDE so it's not even possible.

    I have had to reset the mobo many....many times but switching that jumper out and i dont know if that has been contributing or not.

    I did a Window Diagnotic a while ago because I keep getting the blue sceen of death and it said that I have a motherboard porblem...yes...i know that WINDOWS...thank you.

    What other info do you guys need?

    Thank you for any help!
  2. Rik

    Rik Banned Posts: 3,814

    What help do you need??
  3. kane702

    kane702 TS Rookie Topic Starter

    Heh, sorry if that was rambling

    I think this is a motherboard issue that windows wont load. It just continually tries to detect the raid that isn't there...
    if I even get that far.
  4. Rik

    Rik Banned Posts: 3,814

    Looks like a new mobo is your only answer!!
  5. kane702

    kane702 TS Rookie Topic Starter

    ...well fudge
  6. Rik

    Rik Banned Posts: 3,814

    You say the mobo has always had problems! What problems has it had??
  7. kane702

    kane702 TS Rookie Topic Starter

    yes, i suppoose it's my fault for not dealing with it earlier but i really didn't think that it would acctaully die.

    These are the big problems I had with it, although they may be cause by my lack of knowlege but I do a very good job of keeping my computer cleaned and running smothly most of the time:

    I bought it specifically for the overcloacking feature. When I over clock it using the bult in BIOS feature and "save and exit" the PC shuts down and i have to reset the motherboard.

    When ever I use a DVD drive for more than five minutes, it goes to that blue screen and does aphysical memory dump. This my not be the motherboard but it I kind-of feel it is.

    I get many, many random crashes. I talked to another guy that has a BIOSTAR motherboard and looked at the reviews on Newegg and there have been many similar problmes.

    I cant really thing if more..but I bet there are!!
  8. kane702

    kane702 TS Rookie Topic Starter

    OK, I took out a stick out of my two 1024MB that were in and it booted. What would cause that?

    There is no sound now and it all seems very unstable but windows laoded and I could back up stuff. I am still getting a new motherboard but any sudgestions on keeping the one I have now working till the new one comes?
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...