TechSpot

DxDiag display and blank screen after video card driver install

By Lashire
Aug 23, 2011
Post New Reply
  1. My problem seems to be two fold.

    1. Dxdiag is reporting everything in display as n/a.

    ------------------
    System Information
    ------------------
    Time of this report: 8/23/2011, 12:15:47
    Machine name: REBECCA-PC
    Operating System: Windows 7 Home Premium 64-bit (6.1, Build 7601) Service Pack 1 (7601.win7sp1_gdr.110622-1506)
    Language: English (Regional Setting: English)
    System Manufacturer: MICRO-STAR INTERNATIONAL CO.,LTD
    System Model: MS-7597
    BIOS: Default System BIOS
    Processor: AMD Phenom(tm) II X4 925 Processor (4 CPUs), ~2.8GHz
    Memory: 4096MB RAM
    Available OS Memory: 4096MB RAM
    Page File: 1040MB used, 7148MB available
    Windows Dir: C:\Windows
    DirectX Version: DirectX 11
    DX Setup Parameters: Not found
    User DPI Setting: Using System DPI
    System DPI Setting: 96 DPI (100 percent)
    DWM DPI Scaling: Disabled
    DxDiag Version: 6.01.7601.17514 32bit Unicode

    ------------
    DxDiag Notes
    ------------
    Display Tab 1: No problems found.
    Sound Tab 1: No problems found.
    Sound Tab 2: No problems found.
    Input Tab: No problems found.

    --------------------
    DirectX Debug Levels
    --------------------
    Direct3D: 0/4 (retail)
    DirectDraw: 0/4 (retail)
    DirectInput: 0/5 (retail)
    DirectMusic: 0/5 (retail)
    DirectPlay: 0/9 (retail)
    DirectSound: 0/5 (retail)
    DirectShow: 0/6 (retail)

    ---------------
    Display Devices
    ---------------
    Card name:
    Manufacturer:
    Chip type:
    DAC type:
    Device Key: Enum\
    Display Memory: n/a
    Dedicated Memory: n/a
    Shared Memory: n/a
    Current Mode: 1280 x 960 (32 bit) (1Hz)
    Driver Name:
    Driver File Version: ()
    Driver Version:
    DDI Version: unknown
    Driver Model: unknown
    Driver Attributes: Final Retail
    Driver Date/Size: , 0 bytes
    WHQL Logo'd: n/a
    WHQL Date Stamp: n/a
    Device Identifier: {D7B70EE0-4340-11CF-B123-B03DAEC2CB35}
    Vendor ID: 0x0000
    Device ID: 0x0000
    SubSys ID: 0x00000000
    Revision ID: 0x0000
    Driver Strong Name: Unknown
    Rank Of Driver: Unknown
    Video Accel:
    Deinterlace Caps: n/a
    D3D9 Overlay: n/a
    DXVA-HD: n/a
    DDraw Status: Not Available
    D3D Status: Not Available
    AGP Status: Not Available

    -------------
    Sound Devices
    -------------
    Description: Speakers (Realtek High Definition Audio)
    Default Sound Playback: Yes
    Default Voice Playback: Yes
    Hardware ID: HDAUDIO\FUNC_01&VEN_10EC&DEV_0887&SUBSYS_14627597&REV_1003
    Manufacturer ID: 1
    Product ID: 100
    Type: WDM
    Driver Name: RTKVHD64.sys
    Driver Version: 6.00.0001.6201 (English)
    Driver Attributes: Final Retail
    WHQL Logo'd: Yes
    Date and Size: 9/14/2010 03:06:26, 2487400 bytes
    Other Files:
    Driver Provider: Realtek Semiconductor Corp.
    HW Accel Level: Basic
    Cap Flags: 0xF1F
    Min/Max Sample Rate: 100, 200000
    Static/Strm HW Mix Bufs: 1, 0
    Static/Strm HW 3D Bufs: 0, 0
    HW Memory: 0
    Voice Management: No
    EAX(tm) 2.0 Listen/Src: No, No
    I3DL2(tm) Listen/Src: No, No
    Sensaura(tm) ZoomFX(tm): No

    Description: Realtek Digital Output (Realtek High Definition Audio)
    Default Sound Playback: No
    Default Voice Playback: No
    Hardware ID: HDAUDIO\FUNC_01&VEN_10EC&DEV_0887&SUBSYS_14627597&REV_1003
    Manufacturer ID: 1
    Product ID: 100
    Type: WDM
    Driver Name: RTKVHD64.sys
    Driver Version: 6.00.0001.6201 (English)
    Driver Attributes: Final Retail
    WHQL Logo'd: Yes
    Date and Size: 9/14/2010 03:06:26, 2487400 bytes
    Other Files:
    Driver Provider: Realtek Semiconductor Corp.
    HW Accel Level: Basic
    Cap Flags: 0xF1F
    Min/Max Sample Rate: 100, 200000
    Static/Strm HW Mix Bufs: 1, 0
    Static/Strm HW 3D Bufs: 0, 0
    HW Memory: 0
    Voice Management: No
    EAX(tm) 2.0 Listen/Src: No, No
    I3DL2(tm) Listen/Src: No, No
    Sensaura(tm) ZoomFX(tm): No

    ---------------------
    Sound Capture Devices
    ---------------------
    -------------------
    DirectInput Devices
    -------------------
    Device Name: Mouse
    Attached: 1
    Controller ID: n/a
    Vendor/Product ID: n/a
    FF Driver: n/a

    Device Name: Keyboard
    Attached: 1
    Controller ID: n/a
    Vendor/Product ID: n/a
    FF Driver: n/a

    Poll w/ Interrupt: No

    2. When I install my video card drivers for my Ati Radeon HD 5670, it will load the Bios screen but when it gets to windows, it goes blank. I can hear it starting up, and if I type in my password on the blank screen it will take me to my background image, but do nothing else.

    I can get to safe mode. If I uninstall the drivers, I can load regularly but can not play any games that need directx. Windows automatically downloads some VGA drivers. When it restarts, the computer returns to blank screen at login.

    Edit: Also, when I do install the ATI drivers, it never tells me that it was installed successfully. Only that it was installed and there were some warnings.
     
  2. Lashire

    Lashire TS Rookie Topic Starter Posts: 26

    I solved both issues. They had to do with use of dual monitors, so it was making my television the primary monitor and not my comp's monitor. Unplugged the television and reinstalled the driver, works perfectly now.
     
  3. Tmagic650

    Tmagic650 TS Ambassador Posts: 21,061   +169

    Thanks for the update :)
     


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.