Failed Flash Update

By linux
Dec 6, 2005
  1. ok guy's i'm new here,

    i'm trying to update a Dual layer Dvd Drive
    ( Btc DRW1008IM )
    the nifty flas tool loads ok , is all happy till the money button, This is the log file

    This firmware can be used on below drives :
    (1) DVDRW IDE1008 .
    Check Sum : 8DE
    Please wait a minute.....
    Execute command errorA!! 5/20/ 0
    Flashing is incorrect!!

    i've tryed a few websites including the manafactures flash tool but just the same error , also tryed with just the dvd drive connected, and no programs runing like it say's to flash. but unfortunalty it wont play,
    please help

    thanks phil
  2. iss

    iss TechSpot Chancellor Posts: 1,994

    Either that is not the correct firmware for your drive or the one yuo downloaded is corrupt. your could try downloading it again.
  3. linux

    linux TS Rookie Topic Starter

    but it on the live update tool i got of the website stamped on the front of the drive it automatically serches for a useable update , downloads it , n then fails withe the same error ,

    cud the drive be locked so it can't be flash upgraded with out me jumping a terminal or something ? or shud i just go get a new 1 , as they're cheep as chips

    thanks phil
  4. iss

    iss TechSpot Chancellor Posts: 1,994

    try going to the site and downloading the correct firmware yourself. I dont think the live update is working properly. you could get another one but if you do I would suggest going with a better drive. BTC is not a quality drive. go with BenQ, pioneer, sony, or plextor.
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...