TechSpot

Far Cry 2 startup issues

By ae86trueno
Oct 25, 2008
  1. So i got fc2 the day it came out through steam, installed it and it ran perfectly fine. Now i moved my computer to another house, and everything is still the same except for my mouse, keyboard and monitor. And now i only get the small startup box (picture thing that loads before the game goes into full screen, don't know what its called...) then my screen flashes black and then exits the game(no sound, just a black screen that changes to my in game resolution settings). I tried updating my monitor and video card drivers (not the nvidia 180 beta drivers that have been causing problems with this game) with no success. Any help would be appreciated, thanks! let me know if you need more info or anything too.

    CPU
    Intel Core 2 Duo E6320 Conroe 1.86GHz
    Motherboard
    evga NVIDIA nForce 680i SLI
    Memory
    G.SKILL 1GB 240-Pin DDR2 SDRAM DDR2 800 x2
    Videocard
    xfx 8600gt 256mb
     
  2. Rage_3K_Moiz

    Rage_3K_Moiz Sith Lord Posts: 5,431   +28

    Tried re-installing the game?
     
  3. ae86trueno

    ae86trueno TS Rookie Topic Starter

    its through steam, so i just downloaded the files
     
  4. Acclamator

    Acclamator TS Rookie Posts: 261

    MinoR ThreaT?

    -Beefz0rz
     
  5. ae86trueno

    ae86trueno TS Rookie Topic Starter

    yes


    I got it to work, i had to change the resolution settings in my profile.
     
  6. Acclamator

    Acclamator TS Rookie Posts: 261

    Ah, leet. What's up buddy?
     
  7. TimeParadoX

    TimeParadoX TS Rookie Posts: 2,273

    Lets turn this thread into a chat room! LOL!
     
  8. Acclamator

    Acclamator TS Rookie Posts: 261

    Hah, well the three of us use to tear up in CS.
     
  9. futbol94

    futbol94 TS Rookie

    had the same problem but also fixed it!
     
  10. POCSTAR

    POCSTAR TS Rookie

    Far Cry 2 - issues??

    Hi folks, I have installed the game and keep getting the message that my video driver need updating? I have already installed the latest NVIDIA drivers for the 8000m series and checked the NVIDIA website to make sure this is correct which it is. Have not tried re-installing yet but fairly confident this will not fix, will try anyway. Could the message be pertaining to my version of Direct x which is currently 10? Has anyone got any ideas, laptop spec is below:

    HP
    AMD 64 x 2 Turion TL 60 2.0ghz
    NVIDIA GeForce 8400m GS 128 mb
    2.00 gb RAM
    Vista 32 bit Ultimate

    Any help would be most welcome.

    Cheers
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...