TechSpot

Firefox keeps prompting me when opening files

By Cory88
Nov 10, 2007
  1. I just downloaded firefox and every time I try to open a file or download anything it prompts me if i want to save it or open it. I have "open with" checked, and i also check the "do this automatically for files like this from now on." However, when I open files of the same kind, the same dialog box comes up??
     
  2. Po`Girl

    Po`Girl TS Rookie Posts: 595

    Hi,

    Go to Tools/Options/Main and look at the "Downloads" section.

    It should be clear from there.

    Always make you sure you Save files to you hard drive,before opening.

    That gives you a chance to have second thoughts about what it might be.:evil:

    Desktop is a convenient place.
     
  3. Cory88

    Cory88 TS Rookie Topic Starter

    Thanks for the reply. But I was wanting the media to just automatically play without firefox asking me if i want to save it or open it. I have the box checked, so I thought that would be enough...
     
  4. Bobbye

    Bobbye Helper on the Fringe Posts: 16,335   +36

    It 's better security to save to your desktop> scan with your AV> then open.

    This is one of the reasons Firefox is a safer browser than Internet Explorer!
     
  5. jobeard

    jobeard TS Ambassador Posts: 9,321   +618

    The desktop is a poor choice for downloads as it clutters up the presentation.
    Use your Browser->Tools to define a location specifically for downloads, like
    \Documents & Settings\YourLogin\Downloads.
     
  6. Cory88

    Cory88 TS Rookie Topic Starter

    Well, these are not files that i'm necessarily downloading. They are streaming videos. Under internet explorer, if I click on a video, it would just open WMP and play the file. Under firefox, it prompts me to save it every time.
     
  7. Po`Girl

    Po`Girl TS Rookie Posts: 595

    You really do want to open it don`t you ?

    First go to Tools/Options/Content/Filetype/Manage -

    and set the default action for each file type.

    and then type about:config in the address bar,click go,and

    look for browser.download.manager.showWhenStarting

    Double click it to set the boolean value to False

    There are plenty of other variables for you to fiddle with,too.
     
  8. Bobbye

    Bobbye Helper on the Fringe Posts: 16,335   +36

    The file can be saved where you want. I use the Desktop, which is the default location, because usually after I handle the file, I delete it. Why have to go looking through the system to do that? It's more about convenience than presentation!
     
  9. jobeard

    jobeard TS Ambassador Posts: 9,321   +618

    Using a Download folder is about organization and control;
    it gives you the fact that the contents CAME from the internet and could be
    suspect.

    To each his own, as there's no single answer.
     
  10. Cory88

    Cory88 TS Rookie Topic Starter

    thanks, tried the dl manager and it worked.
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...