TechSpot

Found New Hardware Hell & Create Longer Restore Point

By Suzy600
Oct 21, 2013
Post New Reply
  1. Suzy600

    Suzy600 TS Member Topic Starter Posts: 34

    Dodoodododoodoooooo
     

    Attached Files:

    LookinAround likes this.
  2. LookinAround

    LookinAround TechSpot Chancellor Posts: 8,372   +167


    Hahaha! :p

    Let's repeat the exercise for the 2nd stage driver.
    > Check if C:\Windows\inf\disk.inf and disk.pnf exist?
    > If either file above is missing look again C:\Windows\System32\DriverStore\FileRepository this time for the folders starting disk.inf
    > Look for the disk.inf folder with the most recent date/time stamp. What is the folder name? Does it contain a disk.inf and .pnf or not?
     
  3. Suzy600

    Suzy600 TS Member Topic Starter Posts: 34

    I have no C:\Windows\inf\disk.inf or disk.pnf 's
    I do have Windows\System32\DriverStore\FileRepository\disk.inf
    The most recent being disk.inf_5c850fad from 09/10/13 - it has a disk.inf and a disk.pnf.
     
  4. LookinAround

    LookinAround TechSpot Chancellor Posts: 8,372   +167

    > Copy both the disk.inf and disk.pnf from that most recent repository folder into C:\Windows\inf
    > Remove USBs and run DriveCleaner again
    > Then reconnect the external disk again

    There's a 3rd driver that gets loaded. Let's see if things maybe work or you have a Trifecta! and all 3 were bad!

    p.s. What did the IT shop do??? I'm sure this driver corruption wasn't intentional but curious what they might have uninstalled/removed??
     
  5. Suzy600

    Suzy600 TS Member Topic Starter Posts: 34

    Here you go...

    Found new Hardware message
    Device Manager - in Other Devices - appears once with a ! - code 1 (would I need to install external disk driver?)
    Ran update driver software - automatic seach - no luck

    According to IT chap - this was what was wrong and what he did...Laptop had virus which had been dealt with but Comodo report also said there was one it couldn't quarartine. IT man tried system restore but it didn't work even in safe mode...he tried something after but I don't have details, then saved my docs etc and reset to factory settings.

    I got it back on 12th Oct and been trying to reinstall ever since.After week of trying, got hold of IT man, who basically said it was fine when he gave it back but he had noticed the ethernet connection wasn't working.He was very vague about when/if he could look at it and sort it out so I thought I'd do some research myself and then I found the link at the beginning on Techspot which seemed to describe my issues.

    Do I have a Trifecta? It sounds impressive.
     
  6. LookinAround

    LookinAround TechSpot Chancellor Posts: 8,372   +167


    Impressive indeed! Never seen someone with all 3 drivers corrupted before! Since it's still not working let's take a look at the 3rd driver in the sequence. It's the "Storage Volume" driver.

    This time look in INF directory for volume.inf and pnf, look in the repository for most recent volume.inf folder. Tell me the folder name and if the inf and pnf are present in the folder

    Also, right click on that Other device in DevMgr->Properties->Detail tab. Click the pulldown to show Hardware IDs and copy/paste the first one (or all is OK) into next post.
     
  7. Suzy600

    Suzy600 TS Member Topic Starter Posts: 34

    Hello

    I'm rather proud of my laptop's Most Corrupted title.

    OK serious stuff - In Windows\inf I do have volume.inf and volume.pnf

    In FileRepository the most recent volume.inf folder is Volume.inf._2abeaeba (dated 10/10/13)

    Other device in DevMgr->Properties->Detail tab. Hardware IDs. Top one on list is...

    USBSTOR\CdRomVirtual_CDROM_______________
     
  8. Suzy600

    Suzy600 TS Member Topic Starter Posts: 34

    Exciting News Flash LA.

    Just tried connecting my ipod out of curiosity - it automatically found driver and now I can see and open my ipod on my iTunes.

    However, Device Manager - Other devices still shows ipod as Unknown Device with ! code 1.

    Oh. I now have a Found New Hardware device for the Unknown Device which is my ipod.

    Happy Stormy Sunday.
     
  9. LookinAround

    LookinAround TechSpot Chancellor Posts: 8,372   +167

    Exciting to see we've made some progress!

    Next, your Other device Hardware ID suggest your CDROM driver installation file may part of the problem too. So this time
    > check Windows/inf for cdrom.inf and cdrom.pnf
    > Check repository for most recent cdrom_inf folder. If needed, copy just the cdrom.inf from the repository to the Windows/inf folder (Windows will rebuild the pnf on its own)

    PLUS: Before you plug in the USB drive, this time also delete C:\Windows\inf\INFCACHE.1 . This forces Windows to rebuild its inf cache file to reflect all Windows/inf updates we've made so far

    Plug in USB drive. If USB drive still has a problem, do another trace: unplug usb, run drivecleanup tool, delete ;the current trace, plug in USB, then give me a copy of the latest trace file
     
  10. Suzy600

    Suzy600 TS Member Topic Starter Posts: 34

    Good Eveing Pumpkin

    I've done cdrom.inf copying as didn't have cdrom.inf or cdrom.pnf in Windows\inf.

    But I can't delete C:\Windows\inf\INFCACHE.1 as Destination Folder Access Denied.

    Humph...what do I do to get round this clever IT person?
     
  11. LookinAround

    LookinAround TechSpot Chancellor Posts: 8,372   +167

     
  12. Suzy600

    Suzy600 TS Member Topic Starter Posts: 34

    Deleted C:\Windows\inf\INFCACHE.1

    Is it best to uninstall "take ownership" or could I need it again soon?

    In Device Manager it now shows in DVD CD Rom drives and has no ! - which is good. DevMgr->Properties->Detail tab. Hardware IDs. USBSTOR\CdRomVirtual_CDROM_______________
    It also appears in Computer. It's definately getting excitng now.

    When I connected to USB I got the Windows Explorer is not responding message which I've been getting a lot recently.

    Would you still like a copy of trace file ? And if yes is that the setupapia.dev.log again?

    Thank you for your patience.
     
  13. LookinAround

    LookinAround TechSpot Chancellor Posts: 8,372   +167


    I'm most happy to try and help :)

    Leave the "take ownership" trick installed. It's handy to have available should you ever be denied access to a folder or file due to access permissions.



    Two things trouble me:
    1) Your IT guy said he did a factory restore?? Hard to believe when you have this many corrupt Windows files on your system. But, of course, is just my own speculation
    2) While I can help fix driver files, I worry if other important files are corrupt that we may not be able to find and fix. Argghh.

    Do you have a Windows Vista install CD?

    Before we try another trace, let's do these first

    1. Right click the Other device again. This time use the pull down menu to copy/paste and show me ALL the Hardware IDs as well as the Compatible IDs for that device

    2. Run System File Checker tool, command sfc /scannow. Then attach a copy of the sfcdetails.txt file

    3. Right click Other Device, select Uninstall. Reboot the machine. See if any better luck with your devices
     
  14. Suzy600

    Suzy600 TS Member Topic Starter Posts: 34

    Now when I connect to USB, device is being recognised, I've just tried my ipod which wasn't recognised in device manager previously, it is now.

    So as I can't give you a Other device, will Disc drives\Apple ipod usb device pull down menus do?

    Hardware IDs
    USBSTOR\DiskApple___iPod____________2.70
    USBSTOR\DiskApple___iPod____________
    USBSTOR\DiskApple___
    USBSTOR\Apple___iPod____________2
    Apple___iPod____________2
    USBSTOR\GenDisk
    GenDisk
    Compatible IDs
    USBSTOR\Disk
    USBSTOR\RAW
    Just started sfc /scannow - will give you results when complete.

    I'll have a look for Vista install CD
     
  15. Suzy600

    Suzy600 TS Member Topic Starter Posts: 34

    I do have the Windows Vista reinstallation disc.

    Despite my lack of knowledge on all things IT related - I too am curious of the first of your troubles. I am strongly considering requesting my money back.

    I am aware my laptop is in the autumn of it's life and may need replaced by a younger, lighter, faster, sleeker model very soon- so if it gets to the stage where we have exhausted all reasonable options I have no qualms ditching it. I would feel satisfied that with your fine & capable assistance that I have done all I can to save it.

    sfc/scannnow still only 85% complete...
     
  16. Suzy600

    Suzy600 TS Member Topic Starter Posts: 34

    2. Run System File Checker tool, command sfc /scannow. Then attach a copy of the sfcdetails.txt file

    I can't find a sfcdetails.txt file - where would it be?

    Is this what you need?

    Windows Resource Protection found corrupt files and successfully repaired
    them. Details are included in the CBS.Log windir\Logs\CBS\CBS.log. For
    example C:\Windows\Logs\CBS\CBS.log

    If I rename C:\Windows\Logs\CBS\CBS.log to txt so I can upload it I get a message warning that if I change the file name extension it may become unusable.

    Confused.
     
  17. LookinAround

    LookinAround TechSpot Chancellor Posts: 8,372   +167

    No worries. It's easily overlooked. Go back to the SFC instruction link I gave you. They provide the instructions to search through the CBS.log file and create the sfcdetails.txt file.

    Do not change anything about the CBS.log file

    Also, if there are no more Other devices AND if you don't see any entries in device manager with a yellow icon that's a good (great!) thing. Any yellow icons still exist in DevMan?
     
  18. LookinAround

    LookinAround TechSpot Chancellor Posts: 8,372   +167

    P.s. And I'm happy to continue on our expedition (it's rather fun so far. OK. I am geek :) ). I just didn't want to set any false expectations in case other problems still exist once we've gone as far/best we can.

    /* EDIT */
    just fyi..I removed some stuff from last 2 posts that, for now, might be un-necessary work.
     
  19. Suzy600

    Suzy600 TS Member Topic Starter Posts: 34

    TaDah...see below.Thank you.

    Just connected my ipod and now have a ! In Dev Manager in Other Devices. Yesterday it recognised my ipod and it was named in Disc drives\Apple ipod usb device. If I use the Found New Hardware message that pops up, it is unable to find driver software for my device but on iTunes the ipod icon appears in the right of the screen.

    I'll try usb drivecleanup.
     

    Attached Files:

  20. Suzy600

    Suzy600 TS Member Topic Starter Posts: 34

    Good Evening

    Now I have Other Devices back here is the only Hardware Id

    UMB\UMBUS
    The is nothing under Compatible Id's
     
  21. Suzy600

    Suzy600 TS Member Topic Starter Posts: 34

    This may be standard but just in case it helps...
    When I unistall my ipod (unknown device) from Other devices, in Universal Serial Bus controllers - USB Mass storage device has a ! with code 21 until I disconnect ipod.
     
  22. Suzy600

    Suzy600 TS Member Topic Starter Posts: 34

    Ran the drivecleanup.exe and rebooted. Connected ipod and the same as above occurred.
    The Driver Software Information shows:
    USB MAss Storage Device - Ready to use
    Apple iPod USB Device - Ready to use
    Unidentified Device - Waiting for user input. - Found New Hardware which can never find the driver
     
  23. LookinAround

    LookinAround TechSpot Chancellor Posts: 8,372   +167

    Just skimmed your posts. Took a quick look, and whaddya know... Windows/inf should also contain a umbus.inf and umbus.pnf too! Do the usual routine and try to get the latest umbus.inf copy from the repository. Let me know if know none is available.

    Retest and let's see what happens next
     
  24. Suzy600

    Suzy600 TS Member Topic Starter Posts: 34

    OK LookinAround
    I've copied umbus.inf into Inf.

    When I connected my ipod initially my ipod showed in DevManager =>Disk drives for a few seconds, but then it disappears and appears in Universal Serial Bus controllers => USB Mass storage device has a ! with code 21.

    I no longer get the remove hardware icon on the task bar.
     
  25. LookinAround

    LookinAround TechSpot Chancellor Posts: 8,372   +167

    1) For the moment, let's only test your flash drive and external hard drive (we'll get to your ipod next)
    2) Also, as part of our "standard procedure", anytime we fix an inf file in Windows/inf delete the INFCACHE.1 file as well. Go ahead and delete INFCACHE.1 now as well before we continue.

    3) Download LogOptions.zip. It contains two .reg files
    > LogDetail.reg updates the registry to turn on detail device manager logging
    > LogDefault.reg updates the registry and returns dev manager logging to its default

    Double click to run LogDetail.reg. We'll leave it that way till we're done with this thread

    3) When you connect your USB flash or your external drive, do they work? If not generate a new trace for each. Remember to run DriveCleanup and delete the old setupapi.dev.log before starting a new trace file for each test
     


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.