TechSpot

Games capped at 60 frames

By Tha General
Jun 5, 2009
  1. HD2400 PCI, Vista 32bit, 8.2 Special Visiontek Drivers. I ask this question on another forum a while back, but thought i would ask here, also because the issue still exist. Its not a bad issue, i was just wondering why alot of games which i am playing will not go over 60 frames.
    I have V-sync off in CCC, and i tried other drivers, and ATT, same thing. GTA 3 did the same thing, it wouldn't go over 60, however when it does over 60 the game plays horrible, so i had to keep turn on frame limiter and it runs at 30 frames and plays normal. Timeshift which i have now does the same thing, 1280x1024 low to high settings, 30-60 frames, but it never goes higher than 60.

    So anyways, is this a Vista issue or something?
     
  2. LNCPapa

    LNCPapa TS Special Forces Posts: 4,210   +424

    It's not a vista issue - more likely a vsync issue within the game if you have it off in the CCC. Remember that games often have controls for vsync as well. If the is no option for it in the game then it's probably programming within the game to enforce it.
     
  3. Tha General

    Tha General TechSpot Paladin Topic Starter Posts: 1,106

    None of the games i am playing that is capped at 60 has those options, but one of them GTA 3 does, but when i turn it off, it goes between 40 and 80 frames, but the game starts to become unstable and unplayable, so thats why i put on frame limiter, which sets the frames to 30 and the game plays just fine.

    I think it is a vista/2400HD issue, because never happen in xp or w2k before. My 8400gs doesn't do it, but i was just wondering thats all. Its not a big deal, because 60 frames is more than perfect.
     
  4. teklord

    teklord TS Guru Posts: 481

    Some games cap the frame rate at 60 FPS. I was playing Max Payne 2 demo and it capped at 60 FPS. If so, then you can't do anything about it, except try to hack the game code yourself to improve the framerate. 60 FPS is very good, so I wouldn't worry too much about that.
     
  5. Tha General

    Tha General TechSpot Paladin Topic Starter Posts: 1,106

    It only seem to happen with my 2400hd in vista. Never happens with XP and the 2400hd
    Also using my 8400gs right now, it does not happen at all. But ya 60 is fine lol.
     
  6. teklord

    teklord TS Guru Posts: 481

    Probably something in your CCC drivers then.
     
  7. fimbles

    fimbles TS Evangelist Posts: 1,160   +198

    I have a similar issue with counter strike source.

    If i disable the vsync in Nvidia control panel, the game will renable it, and i will be limited to 60 fps. the same max refresh rate (60hz) as my monitor at 1440 x 900.

    If i disable vsync in the games options i get around 200 fps..

    Luckily most of the games i play have the vsync option in game.

    I know this does not really help your situation, But im just pointing out i have the same issues with nvidia drivers.. so maybe it is vista??

    BTW: Im running vista x64.
     
  8. teklord

    teklord TS Guru Posts: 481

    So in other words, you have to disable it twice. The first time in the drivers and the second in the program itself. This is what I am reading you saying.
     
  9. fimbles

    fimbles TS Evangelist Posts: 1,160   +198

    Well. It seems to make no diffrence if vsync is set to on or off in the nvidia control panel. it still runs at 60 fps.

    Its only the in game option that actually disables vsync.

    I would presume that nvidia control panel would have priority over the game, but it dosent.
     
  10. Tha General

    Tha General TechSpot Paladin Topic Starter Posts: 1,106

    MY GUESS its a vista issue, with certain cards, because it only happens with the 2400hd, not the 8400gs.
     
  11. Tha General

    Tha General TechSpot Paladin Topic Starter Posts: 1,106

    Problem solve = just forgot to mention, Vista drivers are the problem. XP drivers which i am using on Vista 32bit , games isn't capped anymore and all of them which were cap are moving between 50-145 frames and very smooth.
     
  12. LinkedKube

    LinkedKube TechSpot Project Baby Posts: 3,481   +44

    Vista drivers involve dx10, maybe that was a issue.
     
  13. hellokitty[hk]

    hellokitty[hk] Hello, nice to meet you! Posts: 3,435   +145

    I would just like to mention that css probably has vsync turned on in the autoexec.cfg, you will have to turn it off there or it will turn vsync back on every time you restart the game.
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...