Had to format my harddrive and now My OS shows TWICE on the windows boot

By msladybug02
Feb 23, 2005
Topic Status:
Not open for further replies.
  1. Can anyone help me?? I've had problems that I finally fixed by formating and starting from scratch. Now the issue that I have is...When Windows starts to boot up, my Home XP OS shows up twice on the boot up list and makes me choose which one to load before it will continue (or I can wait 25 seconds and it will load on it's own)
    Funny thing is if you click the top choice it boots up, if you click the bottom choice you get an error basically telling you that it doesn't exist. I have seen this before when we upgraded one of our old computers from 98 to 2000, both of them showed up before booting except now it's doing it with the same OS.

    Is there any way to go into the bios and have windows load on the obviously good OS and not have the empty one show up on a list causing a delay in loading? :hotbounce
    Thanks
  2. RealBlackStuff

    RealBlackStuff Newcomer, in training Posts: 8,165

    Welcome to TechSpot

    Click on Start/Run and typ in notepad c:\boot.ini and click OK.
    You will see something like this:

    [boot loader]
    timeout=25
    default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
    [operating systems]
    multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Good Windows XP" /fastdetect
    multi(0)disk(0)rdisk(0)partition(3)\WINDOWS="Bad Windows XP" /fastdetect

    Change: timeout=25 to: timeout=0
    the text AFTER default= must be the SAME as the corresponding part of the Good XP (made bold in the example above.

    Delete the line which contains the Bad XP. Save the file and exit Notepad.
    Reboot and all should be well.
  3. msladybug02

    msladybug02 Newcomer, in training Topic Starter

    Click on Start/Run and typ in notepad

    Thanks for the info! :)
    I ran into a little problem though...here is what I have..

    [boot loader]
    timeout=30
    default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
    [operating systems]
    multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Home Edition" /fastdetect /NoExecute=OptIn
    multi(0)disk(0)rdisk(0)partition(2)\WINDOWS="Microsoft Windows XP Home Edition" /fastdetect


    So I tried changing the timeout to 0 like you said and tried to save that change and I got an error that it was a read only file..
    Also, I don't have a bad XP for me to delete..So I would delete (2)? because (1) is the default area right?
    This is a cool trick that I'll have to remember..but how can I save my changes if it's a read only?
  4. SNGX1275

    SNGX1275 TS Forces Special Posts: 12,409   +281

    They are pointing at 2 different partitions. Do they both load Windows properly? Is it the same install of Windows? Because right now my guess is that only 1 of them works. Are you selecting the top one when you reboot? If so do this:
    The file is C:\boot.ini find that right click on it go to properties and uncheck read only. Then just set the timeout to 0. Save. You don't need to do anything else. Problem solved.

    If you are choosing the 2nd one on the list, just change the timeout to 0, and change the line that starts with default, and replace that (1) with a (2).
  5. msladybug02

    msladybug02 Newcomer, in training Topic Starter

    Thank you very much for your help...This was my first time formatting my existing system.
    You were right..I used the same OS to reload so that I could just start clean..Had to go into the bios to boot from CD in order to format and start fresh.
    I was kind of surprised to see my OS name listed twice on the list even though only 1 was valid. The top one is the one that I have to click on in order to load.

    When I get home from work, I will follow your instruction. Thank you guys very much for the help. :blush:
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.