Half-Life 2 wont run if Refresh Rate is over 60Hz.

By Obi-Wan Jerkobi
Mar 5, 2008
  1. lol It's me again.

    This time its a software type of problem...

    I've bought the orange box and before I was able to play fine, without any wierdness in any of the games. Recently, when playing HL2, if my refresh rate is over 60 hertz then it will not run. It will start up but it will immediately close afterwards. If I run it at 60Hz it will work but it takes forever for it to get to the menu screen. (It will play the valve music but it won't display any picture until you get to the HL2 menu.)

    It's not really a problem since all my other computers run on a monitor at 60Hz but why is it doing this?
  2. mopar man

    mopar man TechSpot Ambassador Posts: 1,379

    Has it had an update recently? How about backing it up, uninstalling, reinstall it and reupdate it. If that doesn't work, try googling it??

    Also, is it a possible monitor problem?
  3. cos

    cos TS Rookie Posts: 39

    I think, looking at your specs you need another gig of ram. and maybe a procesor upgrade. I found Episode 1 totally greedy resorce wise. The only way i could play was double my ram 2 2 gig.
  4. Obi-Wan Jerkobi

    Obi-Wan Jerkobi TS Maniac Topic Starter Posts: 502

    Actually Episode 1 and 2 run great at any refresh rate. It's just regular Half-Life 2 that has the problems. Tried reinstalling it. It does it less now. I can stop it from crashing if I change it to the correct refresh rate and resolution in-game.
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...